Bug 848832 - Multiple DNS entries when booting the RHEV-H image
Multiple DNS entries when booting the RHEV-H image
Status: CLOSED DUPLICATE of bug 834286
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhev-hypervisor6 (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 10:16 EDT by Javier Peña
Modified: 2016-04-26 12:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 10:24:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Peña 2012-08-16 10:16:47 EDT
Description of problem:

While booting the RHEV-H image from the ISO, I want to specify more than one DNS server. According to the Hypervisor Deployment Guide (https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Virtualization/3.0/html/Hypervisor_Deployment_Guide/sect-Deployment_Guide-RHEV_Hypervisor_Kernel_Parameters_and_Automated_Installation-Networking_and_RHEV_Manager_parameters.html), I should use a colon as a separator for the two IP addresses. However, this does fail. No DNS entries are added, and the following is found at /var/log/ovirt.log after installation:

2012-08-16 08:51:45,648 - DEBUG - network - Setting DNS server 1: 10.92.64.27:10.92.64.28
2012-08-16 08:51:45,652 - WARNING - network - Failed to set DNS servers
2012-08-16 08:51:45,652 - DEBUG - network - Updating resolv.conf backups

Using a different notation (comma as the separator) works as expected, so I wonder whether this should be a documentation bug. I have traced the root cause of this to the /usr/lib/python-2.7/site-packages/ovirtnode/network.py file, where is splits the DNS entries using comma as a separator:

DNS = DNS.split(",")


Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. Boot from the RHEV-H ISO image, with the following parameters:

dns=X.Y.Z.A:A.B.C.D install  <any other required parameter>

2. At the end of the installation, check /var/log/ovirt.log
3. Try using the following parameters:

dns=X.Y.Z.A,A.B.C.D install

4. It should work then.
  
Actual results:
DNS entries not added.

Expected results:
DNS entries added.

Additional info:
Comment 2 Mike Burns 2012-08-16 10:24:31 EDT

*** This bug has been marked as a duplicate of bug 834286 ***

Note You need to log in before you can comment on or make changes to this bug.