Bug 834433 - Internal Server Error - Create Cobbler System Record
Internal Server Error - Create Cobbler System Record
Status: CLOSED DUPLICATE of bug 817816
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-06-21 17:09 EDT by Steven Crothers
Modified: 2012-11-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 10:13:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Catalina.out snippet for this partciular exception (5.50 KB, text/plain)
2012-06-21 17:09 EDT, Steven Crothers
no flags Details

  None (edit)
Description Steven Crothers 2012-06-21 17:09:15 EDT
Created attachment 593597 [details]
Catalina.out snippet for this partciular exception

Description of problem:
I receive an Internal Server Error clicking "Create Cobbler System Record" on the provisioning tab of any system.

Version-Release number of selected component (if applicable):
spacewalk-java-lib-1.8.89-1.el6.noarch
spacewalk-java-config-1.8.89-1.el6.noarch
spacewalk-java-1.8.89-1.el6.noarch
spacewalk-java-postgresql-1.8.89-1.el6.noarch

How reproducible:
100% of the time on every system.

Steps to Reproduce:
1. Select a system
2. Select the system's provisioning tab
3. Click "Create Cobbler System Record" form button at the bottom of the page.
4. Internal Server Error
  
Actual results:
Internal Server Error

Expected results:
Successful creation of a Cobbler System record and success message on the Spacewalk page and screen advancement to a next step if any exists.

Additional info:
It appears the Cobbler record is created, upon clicking the button Cobbler states the following:
[root@spacewalk /var/log/tomcat6]# cobbler system list
   det1syslog01lp.XXX.XXX.XXX:2

This system is correct and the profile does indeed exist.

I am attaching the catalina.out log for this specific exception.
Comment 1 Jan Pazdziora 2012-06-27 10:13:57 EDT

*** This bug has been marked as a duplicate of bug 817816 ***

Note You need to log in before you can comment on or make changes to this bug.