Bug 834509 - yum no longer honors -e0 -d0 quiet flag
yum no longer honors -e0 -d0 quiet flag
Status: CLOSED DUPLICATE of bug 831291
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 02:58 EDT by Wolfgang Rupprecht
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 06:56:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Rupprecht 2012-06-22 02:58:07 EDT
Description of problem:
yum evoked as the following is supposed to be quiet.  This used to work for many years with earlier fedora versions.  It now prints unwanted progress reports for the downloads.

 yum -y -e0 -d0 --skip-broken update

Version-Release number of selected component (if applicable):

  yum.noarch                        3.4.3-26.fc17                         @updates


How reproducible:

Always or at least mostly. This runs only once per day and yum caching makes it hard to tell how often it fails.

Steps to Reproduce:
1. run: "yum -y -e0 -d0 --skip-broken update"
2. notice that download progress reports are printed to the terminal
  
Actual results:

progress report output gets printed 

Expected results:

Yum is quiet except for error msgs.

Additional info: 

This is the output I saw tonight:


(1/2): rpmfusion-nonfree-updates/primary_db              |  24 kB     00:00     

(2/2): rpmfusion-free-updates/primary_db                 |  48 kB     00:00     

ffmpeg-libs-0.10.4-1.fc17 0% [                ]  0.0 B/s |  37 kB     --:-- ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [-               ]  94 kB/s | 163 kB     00:37 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=-              ] 126 kB/s | 352 kB     00:26 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=-              ] 129 kB/s | 409 kB     00:25 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [===             ] 179 kB/s | 701 kB     00:16 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [===-            ] 188 kB/s | 820 kB     00:15 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [====-           ] 241 kB/s | 1.1 MB     00:10 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=====-          ] 264 kB/s | 1.3 MB     00:08 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [======-         ] 286 kB/s | 1.5 MB     00:07 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=======         ] 306 kB/s | 1.7 MB     00:06 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [========        ] 324 kB/s | 1.9 MB     00:05 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=========       ] 342 kB/s | 2.0 MB     00:04 ETA 

ffmpeg-libs-0
 .10.4-1.fc17 0% [=========-      ] 359 kB/s | 2.2 MB     00:03 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [==========-     ] 374 kB/s | 2.4 MB     00:03 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [===========-    ] 389 kB/s | 2.6 MB     00:02 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [============    ] 403 kB/s | 2.8 MB     00:02 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=============   ] 416 kB/s | 3.0 MB     00:01 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=============-  ] 413 kB/s | 3.1 MB     00:01 ETA 

ffmpeg-libs-0.10.4-1.fc17 0% [=============== ] 445 kB/s | 3.4 MB     00:00 ETA 

ffmpeg-libs-0.10.4-1.fc17.x86_64.rpm                     | 3.6 MB     00:06
Comment 1 Zdeněk Pavlas 2012-06-22 03:45:01 EDT
Hi, please what version of python-urlgrabber are you using?
This is probably a duplicate of Bug 831291, which has been fixed in python-urlgrabber-3.9.1-13.fc17.
Comment 2 Wolfgang Rupprecht 2012-06-22 03:52:03 EDT
python-urlgrabber.noarch             3.9.1-12.fc17              @updates-testing

I'll update to -13 and see if that helps.
Comment 3 Wolfgang Rupprecht 2012-06-22 04:11:32 EDT
python-urlgrabber-3.9.1-13.fc17 works for me.  Thanks!

I'll leave karma at https://admin.fedoraproject.org/updates/FEDORA-2012-9500/python-urlgrabber-3.9.1-13.fc17
Comment 4 Zdeněk Pavlas 2012-06-22 06:56:24 EDT

*** This bug has been marked as a duplicate of bug 831291 ***

Note You need to log in before you can comment on or make changes to this bug.