Bug 834560 - USBredir does not present PSTN modems / SmartCard Readers as serial devices
USBredir does not present PSTN modems / SmartCard Readers as serial devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: usbredir (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
: ZStream
: 842358 846659 854683 (view as bug list)
Depends On:
Blocks: 808057 858776
  Show dependency treegraph
 
Reported: 2012-06-22 08:22 EDT by John Walicki
Modified: 2013-02-21 03:50 EST (History)
6 users (show)

See Also:
Fixed In Version: usbredir-0.5.1-1.el6
Doc Type: Bug Fix
Doc Text:
Due to a bug in the libusbredirhost library, handling of timeouts for bulk transfers did not work correctly. Consequently, traffic of USB ACM serial port devices, such as PSTN modems and SmartCard readers, could not be properly redirected. With this update, no timeout is set on the usb-host side for these devices and the traffic redirection works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:50:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Walicki 2012-06-22 08:22:38 EDT
Description of problem:
We have real business / use cases for PSTN modems, GPS modules and SmartCard Readers to be exposed to KVM Windows instances. These cards need to present themselves as a serial port but are not working with USBredir.

I understand there is a USBredir test package with this patch that improves this
capability.  I request that this patch be included in a future RHEL 6.3 z-stream.

Details here:
http://cgit.freedesktop.org/spice/usbredir/commit/?id=7783d3db61083bbf7f61b1ea8608c666b4c6a1dd
Comment 2 Hans de Goede 2012-08-06 09:09:38 EDT
Note to QA, verifying this bug requires exotic hardware, which I had on lone to reproduce / fix and no longer have, therefor I suggest verifying this sanity only. Basically check the SRPM that this commit is present:
http://cgit.freedesktop.org/spice/usbredir/commit/?id=7783d3db61083bbf7f61b1ea8608c666b4c6a1dd
Comment 4 Hans de Goede 2012-08-15 03:30:19 EDT
*** Bug 846659 has been marked as a duplicate of this bug. ***
Comment 7 Hans de Goede 2012-09-19 07:47:59 EDT
This is fixed by the new usbredir-0.5.1 upstream release.
Comment 8 Thorsten Hesemeyer 2012-09-19 08:07:21 EDT
*** Bug 854683 has been marked as a duplicate of this bug. ***
Comment 10 Hans de Goede 2012-09-21 03:37:10 EDT
This is fixed by usbredir-0.5.1-1.el6, moving to modified.
Comment 13 Hans de Goede 2012-12-14 05:56:17 EST
*** Bug 842358 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2013-02-21 03:50:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0346.html

Note You need to log in before you can comment on or make changes to this bug.