Bug 846659 - Can`t use BlackBerry Desktop Software under KVM Windows guest
Can`t use BlackBerry Desktop Software under KVM Windows guest
Status: CLOSED DUPLICATE of bug 834560
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: usbredir (Show other bugs)
6.3
x86_64 All
high Severity high
: rc
: 6.3
Assigned To: Hans de Goede
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 07:16 EDT by Martin Kopal
Modified: 2013-01-09 07:06 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 03:30:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kopal 2012-08-08 07:16:39 EDT
Description of problem:

I am not able to get working my BlackBerry with the BlackBerry Desktop Software under KVM Windows guest. Whole system is updated.
In the Virtual Machine Manager I changed Controller USB to USB 2 model and added 4 Redirected USB (type: spicevmc).
Connected to the guest through virt-viewer with an option to redirect USB device directly to the Windows guest.
Guest system is detecting connected device correctly but after you start up BlackBerry Desktop Software it`s disconnected. 

Logs from /var/log/messages is flooded with the following:

Aug  8 13:00:48 sektor kernel: [12744.192995] usb 2-1.2: new high-speed USB device number 9 using ehci_hcd
Aug  8 13:00:48 sektor kernel: [12744.279029] usb 2-1.2: New USB device found, idVendor=0fca, idProduct=8004
Aug  8 13:00:48 sektor kernel: [12744.279039] usb 2-1.2: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Aug  8 13:00:48 sektor kernel: [12744.279045] usb 2-1.2: Product: RIM Composite Device
Aug  8 13:00:48 sektor kernel: [12744.279049] usb 2-1.2: Manufacturer: Research In Motion
Aug  8 13:00:48 sektor kernel: [12744.279053] usb 2-1.2: SerialNumber: FD032408653A3F55E641A46E05B2BCE5301BC8B0
Aug  8 13:00:48 sektor kernel: [12744.290061] scsi13 : usb-storage 2-1.2:1.1
Aug  8 13:00:48 sektor kernel: [12744.290529] scsi14 : usb-storage 2-1.2:1.2
Aug  8 13:00:48 sektor mtp-probe: checking bus 2, device 9: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2"
Aug  8 13:00:51 sektor kernel: [12746.782055] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:00:51 sektor kernel: [12747.344754] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:15 sektor kernel: [12831.034347] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:15 sektor kernel: [12831.271851] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:21 sektor kernel: [12836.536715] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:21 sektor kernel: [12836.775207] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:26 sektor kernel: [12842.184761] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:27 sektor kernel: [12842.422205] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:32 sektor kernel: [12847.691080] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:32 sektor kernel: [12847.928547] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:37 sektor kernel: [12853.275247] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:38 sektor kernel: [12853.512726] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd

It continues with it until I disconnect the device from the system.
From time to time I am able to get it work for about a minute but not for long and the error appears (BDS showing device as disconnected).

This setup has been tested under RHEL 6.3 with the same results.

Similar results are visible with PC Suite and Nokia mobile as well thus not only with the BB devices.

Version-Release number of selected component (if applicable):

qemu-1.0-18
qemu-kvm-1.0-18
usbredir-0.4.3-1
virt-viewer 0.5.3
Guest systems tested : Win7 and WinXP
BDS 7.1.0.23

This problem wasn`t visible on older RHEL 6.2 system with USBR.

How reproducible:

Install Win OS under KVM guest and try to connect to the usb device using BB desktop software.


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Aug  8 13:02:21 sektor kernel: [12836.775207] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:26 sektor kernel: [12842.184761] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:27 sektor kernel: [12842.422205] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:32 sektor kernel: [12847.691080] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:32 sektor kernel: [12847.928547] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:37 sektor kernel: [12853.275247] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd
Aug  8 13:02:38 sektor kernel: [12853.512726] usb 2-1.2: reset high-speed USB device number 9 using ehci_hcd

Expected results:

Connected to the device with no such errors.

Additional info:
Comment 2 Hans de Goede 2012-08-14 11:29:21 EDT
Hi,

2 things (to cover some known and fixed bugs):
1) Are you plugging the phone into a USB-3 port, if so can you try plugging it into a USB-2 port ?
2) Can you try upgrading usbredir to this version (I know this is for Fedora, but it should work fine on
    RHEL too):
http://koji.fedoraproject.org/koji/buildinfo?buildID=344919

Thanks,

Hans
Comment 5 Martin Kopal 2012-08-15 03:23:30 EDT
Hi,

I am using Lenovo T420 with no USB3 port available.

I have installed package you have provided and I can confirm that now I am able to connect to the BB with BlackBerry Desktop Software with no such errors.

Thank you
Comment 6 Hans de Goede 2012-08-15 03:30:19 EDT
(In reply to comment #5)
> Hi,
> 
> I am using Lenovo T420 with no USB3 port available.
> 
> I have installed package you have provided and I can confirm that now I am
> able to connect to the BB with BlackBerry Desktop Software with no such
> errors.
> 
> Thank you

That is good news, thanks for testing! You should be able to use that package without any issues as a workaround for now. I'm going to mark this bug as a duplicate of another bug which is tracking getting the fix present in that Fedora package into a future RHEL-6 release.

*** This bug has been marked as a duplicate of bug 834560 ***

Note You need to log in before you can comment on or make changes to this bug.