Bug 83459 - [GinGin beta 4] - kbdrate in X windows terminal causes continuous carriage returns
[GinGin beta 4] - kbdrate in X windows terminal causes continuous carriage re...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-02-04 12:02 EST by Larry Troan
Modified: 2016-04-18 05:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.20.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 14:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2003-02-04 12:02:39 EST
Type /usr/sbin/kbdrate in X windows causes continuous carriage returns. This
affects everything is X, as it does not stop when the terminal is closed.
Anything subsequently highlighted by the mouse will be continuously selected,
since the carriage returns do not stop until X is restarted

Note:
If the same /usr/sbin/kbdrate is executed in ttys then it works fine giving the
keyboard repeat rate and delay time. 
----------
Action by: jhull
Issue Registered

ISSUE TRACKER 14902, opened as sev 2.
Comment 1 Larry Troan 2003-02-11 09:31:39 EST
Adrian, Any update on this?
Comment 2 Eido Inoue 2003-08-01 17:35:23 EDT
This appears fixed with the 1.20.1 in rawhide
Comment 3 Gary Lerhaupt 2004-05-24 17:16:44 EDT
Where can version 1.20 be found?  1.12 is in FC2 and it still has 
this problem.  Reopening for clarification.
Comment 4 Eido Inoue 2004-10-28 14:43:03 EDT
In current releaes, carriage returns are emmitted (to measure the
rate), but after about 10 of them kbdrate properly reports the rate.

kbdrate without any arguments attempts to send sequences that reset
the rate and other things-- giving the side effect of the carriage
returns. These sequences have no effect in an X window environment,
and end up appearing as carriage returns.

As the bugzilla was for "continuous carriage returns", closing the bug
as this is solved in the supported releases.

Note You need to log in before you can comment on or make changes to this bug.