Bug 83460 - ide-scsi doesn't work
ide-scsi doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-02-04 12:10 EST by Bill Nottingham
Modified: 2014-03-16 22:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-24 09:28:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console output from cdrecord (2.74 KB, text/plain)
2003-02-06 12:47 EST, Gene Czarcinski
no flags Details

  None (edit)
Description Bill Nottingham 2003-02-04 12:10:30 EST
Pioneer DVR-A03.

Attempting to burn CDs results in:
scsi : aborting command due to timeout : pid 2825, scsi0, channel 0, id 0, liun
0, Test Unit Ready 00 00 00 00
Comment 1 Alan Cox 2003-02-04 12:17:18 EST
Controller ?
Boot messgaes ?
dmesg on timeout
Does it occur if you remove magicdev ?
hdparm for the device too (so I can check DMA mode etc)

Thanks
Alan
Comment 2 Bill Nottingham 2003-02-04 12:19:19 EST
Controller: ICH4

More info shortly, testing 2.4.18-24.8.0 on same userland to see if it works better.
Comment 3 Bill Nottingham 2003-02-04 12:43:23 EST
Still fails with 2.4.18-24.8.0. Fails *only* on CD-RW, not on CD-R.

[root@apone notting]# hdparm /dev/hdd
 
/dev/hdd:
 HDIO_GET_MULTCOUNT failed: Invalid argument
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 BLKRAGET failed: Invalid argument
 HDIO_GETGEO failed: Invalid argument

Fails with magicdev removed.

boot messages:
PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH4: IDE controller at PCI slot 00:1f.1
PCI: Found IRQ 5 for device 00:1f.1
PCI: Sharing IRQ 5 with 00:1d.2
ICH4: chipset revision 1
ICH4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:pio, hdd:DMA
hda: MAXTOR 6L040J2, ATA DISK drive
blk: queue c03e9ac0, I/O limit 4095Mb (mask 0xffffffff)
hdd: PIONEER DVD-RW DVR-103, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: host protected area => 1
hda: 78177792 sectors (40027 MB) w/1819KiB Cache, CHS=4866/255/63, UDMA(100)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 hda12 >

The errors on write are the error posted, and things like:
cdrecord: Input/output error. test unit ready: scsi sendcmd: no error
CDB:  00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 02 00 00 00 00 0E 00 00 00 00 30 00 00 00
Sense Key: 0x2 Not Ready, Segment 0
Sense Code: 0x30 Qual 0x00 (incompatible medium installed) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.006s timeout 200s
cdrecord: No disk / Wrong disk!

Moving back to cdrecord-1.10 didn't appear to help. Writing cd-rws on this
drive *has* worked before.

Comment 4 Gene Czarcinski 2003-02-06 12:46:14 EST
I got something similar.  With kernel 2.4.20-2.34 running on a non-smp system, I
was attempting to burn re0204.  It did burn some of the cdrom but got errors at
the end.  I will attach the console output from cdrom.
Comment 5 Gene Czarcinski 2003-02-06 12:47:02 EST
Created attachment 89904 [details]
console output from cdrecord
Comment 6 Harald Hoyer 2003-02-07 04:54:53 EST
i have one or two CD-RWs where the media is bad... Could not blank them.. had to
hardreset
Any magicdev/autorun running?
Comment 7 Bill Nottingham 2003-02-07 12:43:54 EST
Tried two different cd-rws; magicdev was not installed, this was either in GNOME
or on the console, so presumably autorun isn't running.
Comment 8 Harald Hoyer 2003-02-10 04:44:21 EST
workx for me, so it must be the kernel with your HW..
Comment 9 Gene Czarcinski 2003-02-15 14:11:29 EST
See bugzilla 83542.  I have found a work-around which is to install cdrecord
from Psyche.  For 8.0.94, this seems to work on both up and smp kernels.
Comment 10 Alan Cox 2003-06-05 10:41:08 EDT
The logged  message says cdrecord made a junk request to the drive
Comment 11 Harald Hoyer 2003-10-24 08:33:22 EDT
how about current rawhide version of cdrecord?
Comment 12 Bill Nottingham 2003-10-24 09:28:04 EDT
Yeah, this is at least working in cdrecord. THe kernel might have other issues.

Note You need to log in before you can comment on or make changes to this bug.