Bug 834646 - IP Address for subscribed 6Server (6.3) system not displayed
IP Address for subscribed 6Server (6.3) system not displayed
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jordan OMara
Sachin Ghai
RHEL63
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 12:23 EDT by James Laska
Modified: 2014-11-09 17:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The IP address of a Red Hat Enterprise Linux 6.3 client did not display in the list of subscribed systems. A fix for BZ#841691 also fixes this issue. The system details page now displays the entire set of network interfaces for the client.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 09:26:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot.png (123.68 KB, image/png)
2012-06-22 12:23 EDT, James Laska
no flags Details
No 'IP:' field in left pane. (76.26 KB, image/png)
2012-09-24 00:15 EDT, Sachin Ghai
no flags Details

  None (edit)
Description James Laska 2012-06-22 12:23:48 EDT
Created attachment 593790 [details]
Screenshot.png

Description of problem:

When viewing the list of subscribed systems, 6Server (6.3) clients do not show the IP Address.  Other clients (5Server [5.8]) display the IP Address properly. 

The system facts for the 6Server system (see screenshot) show the IP address is available.  Perhaps the wrong field is displayed in the UI?

Version-Release number of selected component (if applicable):
 * candlepin-0.6.5-1.el6_2.src.rpm
 * katello-0.1.317-1.el6_2.src.rpm
 * katello-candlepin-cert-key-pair-1.0-1.src.rpm
 * katello-certs-tools-1.0.7-1.el6_3.src.rpm
 * katello-cli-0.1.111-1.el6_2.src.rpm
 * katello-configure-0.1.110-1.el6_3.src.rpm
 * katello-qpid-broker-key-pair-1.0-1.src.rpm
 * katello-qpid-client-key-pair-1.0-1.src.rpm
 * katello-selinux-0.1.10-1.el6.src.rpm
 * pulp-1.0.4-1.el6.src.rpm
 * python-qpid-0.14-8.el6.src.rpm
 * qpid-cpp-0.14-16.el6.src.rpm

How reproducible:


Steps to Reproduce:
1. Subscribe a RHEL-6.3 system to CloudForms System Engine
2. On CFSE, select: Systems -> All
3. Look at the entry for the corresponding RHEL-6.3 system
  
Actual results:

See screenshot, the IP Address field is empty

Expected results:

See screenshot, the IP Address should be filled in

Additional info:
Comment 1 James Laska 2012-06-22 13:59:12 EDT
Additional info:
 * This appears to *ONLY* impact RHEL-6.3 systems.  RHEL-6.2 subscribed systems show the IP address
Comment 2 Jordan OMara 2012-07-25 14:59:58 EDT
This is probably based on a recent change to subman & candlepin. I think based on the fix here:

https://bugzilla.redhat.com/show_bug.cgi?id=841691

This won't be an issue anymore
Comment 4 Sachin Ghai 2012-09-24 00:14:49 EDT
I was verifying this defect against latest cfse puddle:


katello-qpid-client-key-pair-1.0-1.noarch
katello-common-1.1.12-7.el6cf.noarch
katello-all-1.1.12-7.el6cf.noarch
katello-cli-1.1.8-4.el6cf.noarch
katello-certs-tools-1.1.8-1.el6cf.noarch
katello-glue-candlepin-1.1.12-7.el6cf.noarch
katello-selinux-1.1.1-1.el6cf.noarch
katello-configure-1.1.9-3.el6cf.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.1.8-4.el6cf.noarch
katello-glue-pulp-1.1.12-7.el6cf.noarch
katello-1.1.12-7.el6cf.noarch
katello-qpid-broker-key-pair-1.0-1.noarch


So to test it, I browsed system -> All --> Selected RHEL6.3 systems. 
But looks like there is no such field with name IP: on left pane. Could you please confirm if that's due to some design changes or I'm hitting with another bug ?

However the system facts are showing correct IP address. Please see the attached screen shot.
Comment 5 Sachin Ghai 2012-09-24 00:15:40 EDT
Created attachment 616358 [details]
No 'IP:' field in left pane.
Comment 6 Jordan OMara 2012-09-24 14:26:53 EDT
Sachin:

Correct, we removed IP Address from the left pane and moved the entire set of interfaces inside the system details page. You should see a "Networking" subsection with Hostname and Interfaces. Check out this guy:

https://github.com/Katello/katello/pull/354/files
Comment 7 Sachin Ghai 2012-10-01 02:28:09 EDT
As per the defect description the "IP" address field from left pane has already been removed. But as per comment 6, the same information with interfaces has been moved to "Networking" subsection and which is not working as per following defect:

https://bugzilla.redhat.com/show_bug.cgi?id=859877
Comment 8 Jordan OMara 2012-10-08 09:26:55 EDT
The bug Sachin mentioned in the last post was a duplicate of ANOTHER bug that is now solved. Marking this as NOTABUG since the original issue was solved in another bz#
Comment 9 Mike McCune 2013-08-16 14:09:02 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.