Bug 859877 - After registering a system, 'Details-> System info' doesn't show the network interfaces
After registering a system, 'Details-> System info' doesn't show the network ...
Status: CLOSED DUPLICATE of bug 859207
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jordan OMara
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 05:18 EDT by Sachin Ghai
Modified: 2014-11-09 17:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 16:12:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no network interfaces displayed for rhel6.2 and rhe6.3 client under 'system info' (69.46 KB, image/png)
2012-09-24 05:18 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-09-24 05:18:07 EDT
Created attachment 616437 [details]
no network interfaces displayed for rhel6.2 and rhe6.3 client under 'system info'

Description of problem:
1. register a system via RHSM
2. Go to Systems ==> select system from left pane ==> Details ==> system Info
3. Check 'interfaces' under 'Networking' section

I tested it against both rhel6.2 and rhel6.3 clients. 

Version-Release number of selected component (if applicable):

katello-qpid-client-key-pair-1.0-1.noarch
katello-common-1.1.12-7.el6cf.noarch
katello-all-1.1.12-7.el6cf.noarch
katello-cli-1.1.8-4.el6cf.noarch
katello-certs-tools-1.1.8-1.el6cf.noarch
katello-glue-candlepin-1.1.12-7.el6cf.noarch
katello-selinux-1.1.1-1.el6cf.noarch
katello-configure-1.1.9-3.el6cf.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.1.8-4.el6cf.noarch
katello-glue-pulp-1.1.12-7.el6cf.noarch
katello-1.1.12-7.el6cf.noarch
katello-qpid-broker-key-pair-1.0-1.noarch


How reproducible:
always
  
Actual results:
No network interfaces displayed under system info 

Expected results:
Network interfaces should be displayed like:

lo :
eth0 :

Additional info:

I'm using following version of subscription-manager on rhel6.2 and rhel6.3 clients.

[root@dhcp201-152 ca]# rpm -qa | grep python-rhsm
python-rhsm-0.96.15-1.el6.noarch
[root@dhcp201-152 ca]# rpm -qa | grep subscription-manager
subscription-manager-0.96.17.2-3.el6_2.x86_64
Comment 1 Sachin Ghai 2012-09-24 05:19:55 EDT
'None' is displayed for ip_address under 'system list' output from cli:


cfse> system list --env dev --org ACME_Corporation
-------------------------------------------------------------------------------------------------------------------------------------------------------------
                                             Systems List For Environment [ dev ] in Org [ ACME_Corporation ]

 Name                                Uuid                                   Ipv4 Address    Service Level  
-------------------------------------------------------------------------------------------------------------------------------------------------------------
 shark.lab.eng.pnq.redhat.com        ef90e123-c213-41af-87dc-03950e167d0b   None                                          
 perceptor.lab.eng.pnq.redhat.com    fcf9b896-af6e-47bc-a7a2-9dcba32f4dda   None                           
 dhcp201-152.englab.pnq.redhat.com   c30c7114-f7ed-470c-891c-6c52a23bf6bb   None
Comment 3 Tom McKay 2012-09-24 09:03:28 EDT
@jomara May or may not be related to https://bugzilla.redhat.com/show_bug.cgi?id=859207
Comment 4 Jordan OMara 2012-10-05 15:45:38 EDT
Figured this out; the ipaddr field was changed in older versions of subman. .96 uses a different field. Added backwards support
Comment 5 Jordan OMara 2012-10-05 16:12:21 EDT
This is actually a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=859207

*** This bug has been marked as a duplicate of bug 859207 ***
Comment 6 Mike McCune 2013-08-16 14:18:47 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.