Bug 834979 - Shortcuts for highlighting text is instead inserting TM result (Alt+Shift+keypad conflict)
Shortcuts for highlighting text is instead inserting TM result (Alt+Shift+key...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6
Unspecified Linux
unspecified Severity high
: ---
: 1.6.1
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 02:36 EDT by Hedda Peters
Modified: 2012-07-03 01:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.6.1-SNAPSHOT (20120628-0014)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 836142 (view as bug list)
Environment:
Last Closed: 2012-07-03 01:27:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-06-25 02:36:31 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build Identifier: 

Using standard keyboard combinations for highlighting text is instead inserting a TM result. 

Reproducible: Always

Steps to Reproduce:
1. Open existing translation in editor, putting the cursor at the end of the string.
2. Hold down Ctrl+Shift, then additionally press left arrow key.

Actual Results:  
The 4th TM match is being inserted into the editor. 

Expected Results:  
Holding down Ctrl+Shift, with each time I hit the left arrow key, he text should be highlighted word by word  -- this is standard text editor behaviour.

Severity medium/high because this behaviour is really unexpected, deletes existing translation inserting and approving a different translation, and there is no undo functionality any more to fix what happened.
Comment 1 Alex Eng 2012-06-25 19:54:20 EDT
Suggest copy from TM shortcut to be change from ALT+SHIFT + 1,2,3,4 to 
CTRL+ATL + 1,2,3,4 to prevent conflict of keypad 4 with left arrow button as result of Shift key being press.
Comment 3 Ding-Yi Chen 2012-06-28 04:17:24 EDT
VERIFIED with Zanata version 1.6.1-SNAPSHOT (20120628-0014)

But problem remains with Zanata version 1.7-SNAPSHOT (20120626-0025)

Note You need to log in before you can comment on or make changes to this bug.