This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 836142 - Shortcuts for highlighting text is instead inserting TM result (Alt+Shift+keypad conflict) [1.7]
Shortcuts for highlighting text is instead inserting TM result (Alt+Shift+key...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6
Unspecified Linux
unspecified Severity high
: ---
: 1.7
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 04:18 EDT by Ding-Yi Chen
Modified: 2012-09-12 20:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.7-SNAPSHOT (20120705-0026)
Doc Type: Bug Fix
Doc Text:
Cause: Conflicting keyboard keys between text selecting in editor and copy from translation memory into editor. Consequence: Users can't use Ctrl+Shift + left arrow key to select text in editor. Fix: See https://bugzilla.redhat.com/show_bug.cgi?id=836051#c2
Story Points: ---
Clone Of: 834979
Environment:
Last Closed: 2012-09-11 01:11:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-06-28 04:18:17 EDT
+++ This bug was initially created as a clone of Bug #834979 +++

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build Identifier: 

Using standard keyboard combinations for highlighting text is instead inserting a TM result. 

Reproducible: Always

Steps to Reproduce:
1. Open existing translation in editor, putting the cursor at the end of the string.
2. Hold down Ctrl+Shift, then additionally press left arrow key.

Actual Results:  
The 4th TM match is being inserted into the editor. 

Expected Results:  
Holding down Ctrl+Shift, with each time I hit the left arrow key, he text should be highlighted word by word  -- this is standard text editor behaviour.

Severity medium/high because this behaviour is really unexpected, deletes existing translation inserting and approving a different translation, and there is no undo functionality any more to fix what happened.

--- Additional comment from aeng@redhat.com on 2012-06-26 09:54:20 EST ---

Suggest copy from TM shortcut to be change from ALT+SHIFT + 1,2,3,4 to 
CTRL+ATL + 1,2,3,4 to prevent conflict of keypad 4 with left arrow button as result of Shift key being press.

--- Additional comment from aeng@redhat.com on 2012-06-26 13:18:40 EST ---

Fixed in 1.6.1

See https://github.com/zanata/zanata/commit/ffec30c5c88f3ebfc2e2b4366a648ab426b0d764

--- Additional comment from dchen@redhat.com on 2012-06-28 18:17:24 EST ---

VERIFIED with Zanata version 1.6.1-SNAPSHOT (20120628-0014)

But problem remains with Zanata version 1.7-SNAPSHOT (20120626-0025)
Comment 1 Hedda Peters 2012-06-28 23:34:13 EDT
Turns out my original bug report (https://bugzilla.redhat.com/show_bug.cgi?id=834979) should have been against the 1.7 version, THAT'S where I've noticed the problem. Sorry for any confusion.

Any hope to have this fixed and deployed for 1.7.x soon? 

I've stalled my current translation assignments because it's too painful working with this bug.
Comment 2 Sean Flanigan 2012-06-28 23:51:04 EDT
Um, 1.7.0 hasn't been released yet.
Comment 3 Hedda Peters 2012-06-28 23:53:57 EDT
Oh gosh... of course, sorry. I'm getting ahead of myself here.

Nevermind, and thank god it's friday. :-D
Comment 4 Alex Eng 2012-07-03 18:37:40 EDT
Issue fixed in 1.7 along with fixes from
https://bugzilla.redhat.com/show_bug.cgi?id=836051#c2
Comment 5 Ding-Yi Chen 2012-07-04 23:22:58 EDT
VERIFIED with 1.7-SNAPSHOT (20120705-0026)

Note You need to log in before you can comment on or make changes to this bug.