Bug 835009 - [virtio-scsi] core dumped after guest system_reset
[virtio-scsi] core dumped after guest system_reset
Status: CLOSED DUPLICATE of bug 805501
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 04:41 EDT by Mike Cao
Modified: 2015-11-22 22:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 04:41:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-06-25 04:41:26 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[root@test whql]# uname -r ;rpm -q qemu-kvm
2.6.32-266.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64

win7-32 bit guest

How reproducible:
100%

Steps to Reproduce:
1.Start Guest w/ one virtio scsi pci and 4 scsi passthrough disks  and -boot menu=on
CLI:/usr/libexec/qemu-kvm -boot menu=on -m 2G -smp 2 --nodefaults -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:52:12:30:F5:22,bus=pci.0,addr=0x6 -uuid bfd8f0f7-1ba7-4c97-9d90-087cb8c5d3c0 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win7_32,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -rtc base=localtime,clock=host,driftfix=slew -drive file=/dev/sdc,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk0 -drive file=/dev/sdd,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk1 -drive file=/dev/sde,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk2 -drive file=/dev/sdf,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk3 -drive file=/dev/sdg,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk4 -device virtio-scsi-pci,id=bus1,bus=pci.0,addr=0x7 -device scsi-block,bus=bus1.0,drive=scsi-disk0,id=disk,serial=test -device scsi-block,bus=bus1.0,drive=scsi-disk1,id=disk1,serial=test1 -device scsi-block,bus=bus1.0,drive=scsi-disk2,id=disk2,serial=test2 -device scsi-block,bus=bus1.0,drive=scsi-disk3,id=disk3,serial=test3 -device scsi-block,bus=bus1.0,drive=scsi-disk4,id=disk4,serial=test4 -bios /usr/share/seabios/bios-pm.bin

2.in the vncviewer ,press F12
3.in qemu-monitor ,press system_reset
  
Actual results:
core dump occurs 

Expected results:


Additional info:

Program terminated with signal 11, Segmentation fault.
#0  0x00007fc04f7edb39 in scsi_req_cancel (req=0x7fc0400008f0)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-bus.c:1391
1391	    if (req->bus->info->cancel) {
Missing separate debuginfos, use: debuginfo-install keyutils-libs-1.4-4.el6.x86_64 krb5-libs-1.9-31.el6.x86_64 libcom_err-1.41.12-12.el6.x86_64 libselinux-2.0.94-5.3.el6.x86_64 libuuid-2.17.2-12.5.el6.x86_64 libvorbis-1.2.3-4.el6_2.1.x86_64 openssl-1.0.0-20.el6_2.2.x86_64 spice-server-0.10.1-10.el6.x86_64 usbredir-0.4.2-1.el6.x86_64
(gdb) bt
#0  0x00007fc04f7edb39 in scsi_req_cancel (req=0x7fc0400008f0)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-bus.c:1391
#1  0x00007fc04f7edb85 in scsi_device_purge_requests (sdev=0x7fc051dd1010, sense=...)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-bus.c:1418
#2  0x00007fc04f7f18c7 in scsi_disk_reset (dev=0x7fc051dd1010)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-disk.c:1534
#3  0x00007fc04f779f3a in qemu_system_reset () at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:3343
#4  0x00007fc04f79db4c in qemu_kvm_system_reset ()
    at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1978
#5  kvm_main_loop () at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2258
#6  0x00007fc04f77ecec in main_loop (argc=20, argv=<value optimized out>, envp=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4202
#7  main (argc=20, argv=<value optimized out>, envp=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6427
(gdb)
Comment 3 Paolo Bonzini 2012-07-12 04:41:27 EDT

*** This bug has been marked as a duplicate of bug 805501 ***

Note You need to log in before you can comment on or make changes to this bug.