Bug 835016 - Cheese and any use of webcam on Samsung N145 Plus freezes the computer
Cheese and any use of webcam on Samsung N145 Plus freezes the computer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 05:11 EDT by Frank
Modified: 2012-12-10 09:17 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 09:17:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank 2012-06-25 05:11:27 EDT
Description of problem: Everytime i try to use webcam on Samsung N145 Plus (cheese, camorama, Skype) the system freezes. It has to be turn off/on to restart


Version-Release number of selected component (if applicable):

Linux 3.4.3-1.fc17.i686
cheese-3.4.2-3.fc17.i686
camorama-0.19-7.fc17.i686
gstreamer-plugins-ugly-0.10.19-1.fc17.i686
gstreamer-plugins-bad-free-0.10.23-7.fc17.i686
gstreamer-plugins-base-0.10.36-1.fc17.i686
PackageKit-gstreamer-plugin-0.7.4-4.fc17.i686
gstreamer-plugins-good-0.10.31-4.fc17.i686
gstreamer-plugins-bad-0.10.22-4.fc17.i686



How reproducible:
try to use web cam with any program
cheese - freezes
camorama - freezes
skype --> options --> video settings - freezes

Steps to Reproduce:
1. start cheese or camorama
2. system freezes
3. have to switch off/on computer
  
Actual results:
whole system freezes, looses existing network connection. Have to hard reboot

Expected results:
webcam turns on and i am able to take pics/video or video chat

Additional info:
dmesg:
[   17.312353] Linux video capture interface: v2.00
[   17.322678] uvcvideo: Found UVC 1.00 device WebCam SCB-0355N (2232:1006)
[   17.324482] input: WebCam SCB-0355N as /devices/pci0000:00/0000:00:1d.7/usb1/
1-8/1-8:1.0/input/input8
[   17.324793] usbcore: registered new interface driver uvcvideo
[   17.324801] USB Video Class driver (1.1.1)

Camera worked fine on F16

CPU0: Intel(R) Atom(TM) CPU N450   @ 1.66GHz stepping 0a
agpgart-intel 0000:00:00.0: Intel GMA3150 Chipset
2GB RAM

System has been upgraded F16 --> F17 using preupgrade
Same problem occurs when running from Live-USB though.

Thanks and regards
Frank
Comment 1 Frank 2012-06-25 05:13:09 EDT
I tried all steps as described in a similar bug 815134.
Comment 2 Hans de Goede 2012-06-25 05:21:24 EDT
Since this happens with other v4l2 apps then cheese, it likely is a kernel bug, changing component.
Comment 3 Frank 2012-06-25 07:42:42 EDT
UPDATE
The OS installed on HDD is i686 architecture.
I just tried LiveOS x86_64 architecture with the following results

stock LiveOS F17 (x86_64 no updates)
 when i run cheese from terminal nothing happens no window opens. I got whole bunch of GTK error messages, but the system doesn't hang. CTRL+C returns back to prompt. No light on the camera comes up.

updated cheese and gstreamer-plugins
 ran "yum update --enablerepo=updates-testing cheese gstreamer*"
 run cheese from terminal --> system hangs

Frank
Comment 4 Justin M. Forbes 2012-12-07 11:08:52 EST
Is this still happening with 3.6.9 kernels?
Comment 5 Frank 2012-12-10 04:12:08 EST
Hi Justin,

just tested with 3.6.9 kernel and the camera appears to be working now. 

Cheese is working fine. 
Camorama is wirking fine.
Skype - camera doesn't show preview in Skype setting. However video calling IS working. It is probably an issue with Skype though.

I believe the bug can be closed.

Thank you 
Frank
Comment 6 Hans de Goede 2012-12-10 09:17:15 EST
Thanks for re-testing, closing.

Note You need to log in before you can comment on or make changes to this bug.