Bug 815134 - Cheese not working with webcam on Thinkpad x120e / x121e
Cheese not working with webcam on Thinkpad x120e / x121e
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-22 14:46 EDT by Ravishankar Srinivasan
Modified: 2012-06-25 04:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 19:57:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of Thinkpad x120e (74.96 KB, text/plain)
2012-04-22 14:48 EDT, Ravishankar Srinivasan
no flags Details
dmidecode for Thinkpad x120e (14.51 KB, text/plain)
2012-04-22 14:49 EDT, Ravishankar Srinivasan
no flags Details
libv4l log when cheese is starting (69.55 KB, text/x-log)
2012-04-30 07:15 EDT, Ravishankar Srinivasan
no flags Details
dmesg - cheese on a 15s delay (78.35 KB, text/plain)
2012-05-22 20:17 EDT, Richard Chan
no flags Details
dmidecode - cheese on 15s delay (14.96 KB, text/plain)
2012-05-22 20:21 EDT, Richard Chan
no flags Details
libv4l log - cheese on 15s delay (477.15 KB, application/octet-stream)
2012-05-22 20:22 EDT, Richard Chan
no flags Details

  None (edit)
Description Ravishankar Srinivasan 2012-04-22 14:46:49 EDT
Description of problem:

Webcam not working properly on F17 Beta with latest updates (4/22) on Thinkpad x120e. Cheese just hangs until Force Quit and skype does not show any video either.webcam light does not come on at all. webcam was working fine in F16 and on a custom 3.3.2 kernel with gentoo. I believe my OEM webcam (SuYin) is supported by the uvcvideo driver

Version-Release number of selected component (if applicable):

Linux jonty 3.3.2-8.fc17.x86_64 #1 SMP Sat Apr 21 12:44:25 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

cheese 3.4.1
uvcvideo driver 1.1.1
Thinkpad X120e
dmesg attached

How reproducible:

Steps to Reproduce:
1. Update F17 Beta to latest version
2. Open Cheese
3. webcam light does not come on and cheese hangs
  
Actual results:

webcam not detected and cheese hangs

Expected results:

webcam should be detected and cheese should work properly

Additional info:

lspci:
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: ATI Technologies Inc AMD Radeon HD 6310 GraphicsATI
00:01.1 Audio device: ATI Technologies Inc Wrestler HDMI Audio [Radeon HD 6250/6310]
00:06.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:15.0 PCI bridge: ATI Technologies Inc SB700/SB800 PCI to PCI bridge (PCIE port 0)
00:15.1 PCI bridge: ATI Technologies Inc SB700/SB800 PCI to PCI bridge (PCIE port 1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
Comment 1 Ravishankar Srinivasan 2012-04-22 14:48:54 EDT
Created attachment 579334 [details]
dmesg of Thinkpad x120e

dmesg for Thinkpad X120e
Comment 2 Ravishankar Srinivasan 2012-04-22 14:49:43 EDT
Created attachment 579335 [details]
dmidecode for Thinkpad x120e

dmidecode for Thinkpad x120e
Comment 3 Hans de Goede 2012-04-23 03:42:20 EDT
Hi,

Can you try the following:

1) Download and install ("rpm -ivh kernel-....") this kernel:
http://koji.fedoraproject.org/koji/buildinfo?buildID=307526
'
Then reboot into it and see if that fixes your problem.

2) If 1) does not "fix" things do "yum install camorama" and
see if the camera works with camorama ?

Note: just trying to figure out which component to blame here.

Regards,

Hans
Comment 4 Ravishankar Srinivasan 2012-04-23 05:13:34 EDT
Hans,

camorama hard locked the system on the F17 3.3 kernel. Noticed webcam light came on and then system froze.  did not even come up in 3.2 koji kernel

installed 3.2.x from koji above and still nothing. cheese shows blank. camera light did not come on

Dunno if this means the issue is somewhere else other than kernel or cheese.
Comment 5 Hans de Goede 2012-04-23 05:23:51 EDT
Hi,

(In reply to comment #4)
> Hans,
> 
> camorama hard locked the system on the F17 3.3 kernel. Noticed webcam light
> came on and then system froze.  did not even come up in 3.2 koji kernel

Can you clarify what you mean with "did not even come up with the 3.2 koji kernel" ?

> installed 3.2.x from koji above and still nothing. cheese shows blank. camera
> light did not come on

With a hard freeze I tend to blame the kernel. You said that it worked fine in F-16 and with a gentoo kernel, right? I'm starting to get a feeling that this may be an xorg-x11-drv-radeon or a mesa problem. Are you using gnome3? Can you try forcing fallback mode and then try camorama again with the latest kernel ?

Thanks,

Hans
Comment 6 Ravishankar Srinivasan 2012-04-23 06:19:48 EDT
Hans,

camorama in fallback mode with latest 3.3 kernel does not come up at all. no ouput from shell no errors in messages noted. can confirm that I am running the radeon DRI with gallium

[ravis@jonty ~]$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on AMD PALM
    GL_EXT_vertex_array_bgra, GL_NV_conditional_render, 


[ravis@jonty ~]$ rpm -qi xorg-x11-drv-ati-6.14.4-5.20120417git0bda305f7.fc17.x86_64
Name        : xorg-x11-drv-ati
Version     : 6.14.4
Release     : 5.20120417git0bda305f7.fc17
Architecture: x86_64
Install Date: Sun 22 Apr 2012 05:16:26 PM IST
Group       : User Interface/X Hardware Support
Size        : 1133377
License     : MIT
Signature   : RSA/SHA256, Thu 19 Apr 2012 01:41:22 AM IST, Key ID 50e94c991aca3465
Source RPM  : xorg-x11-drv-ati-6.14.4-5.20120417git0bda305f7.fc17.src.rpm
Build Date  : Tue 17 Apr 2012 11:29:37 PM IST
Build Host  : x86-09.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.x.org
Summary     : Xorg X11 ati video driver
Description :
X.Org X11 ati video driver.
[ravis@jonty ~]$ rpm -ql xorg-x11-drv-ati-6.14.4-5.20120417git0bda305f7.fc17.x86_64
/usr/lib64/xorg/modules/drivers/ati_drv.so
/usr/lib64/xorg/modules/drivers/radeon_drv.so
/usr/share/man/man4/ati.4.gz
/usr/share/man/man4/radeon.4.gz
Comment 7 Hans de Goede 2012-04-23 09:32:52 EDT
(In reply to comment #6)
> Hans,
> 
> camorama in fallback mode with latest 3.3 kernel does not come up at all. no
> ouput from shell no errors in messages noted. can confirm that I am running the
> radeon DRI with gallium

Hmm, but when you tried before (without fallback mode) it froze the machine right? That is weird,
did you start camorama from a terminal? And where there any messages on the terminal? If not can you
try starting it from a terminal and see if there are any messages?

Also can you do "dmesg" after trying camorama and see if there are any relevant messages there?
Comment 8 Ravishankar Srinivasan 2012-04-26 04:37:54 EDT
Hi Hans,

I noticed something weird. camorama was showing no output so i checked using file /usr/bin/camorama and it sad empty! no wonder it showed no output!. looks like the first hard lock corrupted the install. I did a yum reinstall and camorama worked in fallback mode!

In the standard graphics mode, i got a hard lock as usual but i did see camera light come on and some garbled junk on the camorama screen. I also did a yum update today and it pulled in 100 MB+ worth of updates, so the problem still exists today in rawhide.

What is your verdict in light of this new data? should i rollback to an older version of the radeon driver?
Comment 9 Hans de Goede 2012-04-26 06:30:37 EDT
(In reply to comment #8)
> Hi Hans,
> 
> I noticed something weird. camorama was showing no output so i checked using
> file /usr/bin/camorama and it sad empty! no wonder it showed no output!.

Heh, yeah. That happens with ext4 sometimes when the system crashes shortly after
creating new files, the files are there but 0 bytes large. Note this is not an ext4
bug just something which happens with ext4 on crashes, the crashing part is the bug.

> like the first hard lock corrupted the install. I did a yum reinstall and
> camorama worked in fallback mode!

Good, so then it is not a webcam driver problem. And likely also not a cheese problem,
but rather a problem with your gfx drivers, probably mesa. Can you also try cheese in
fallback mode please?

> In the standard graphics mode, i got a hard lock as usual but i did see camera
> light come on and some garbled junk on the camorama screen. I also did a yum
> update today and it pulled in 100 MB+ worth of updates, so the problem still
> exists today in rawhide.
> 
> What is your verdict in light of this new data? should i rollback to an older
> version of the radeon driver?

For starters I would try rolling back to an older version of mesa, if you're on rawhide I
would start with trying the F-17 mesa packages.

Regards,

Hans
Comment 10 Ravishankar Srinivasan 2012-04-29 04:33:35 EDT
ok more news. Did a yum update and pulled in lotsa changes today. camorama worked on standard mode without any issues, however cheese still hangs and does not start the webcam. i.e i don't see camera light come on

I can confirm that skype works too after latest round of updates! 

bug in cheese then for sure?
Comment 11 Ravishankar Srinivasan 2012-04-29 04:35:27 EDT
and oh for some weird reason, when i run cheese from the console, it does not come up at all. all i see is 


(cheese:2744): Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkButton, but as a GtkBin subclass a GtkButton can only contain one widget at a time; it already contains a widget of type GtkLabel

(cheese:2744): Gtk-WARNING **: Attempting to add a widget with type GtkGrid to a GtkToggleButton, but as a GtkBin subclass a GtkToggleButton can only contain one widget at a time; it already contains a widget of type GtkLabel

(cheese:2744): Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkButton, but as a GtkBin subclass a GtkButton can only contain one widget at a time; it already contains a widget of type GtkLabel
Comment 12 rminkler 2012-04-29 15:10:10 EDT
I'm having this problem too.
Comment 13 Hans de Goede 2012-04-30 02:20:15 EDT
(In reply to comment #10)
> ok more news. Did a yum update and pulled in lotsa changes today. camorama
> worked on standard mode without any issues, however cheese still hangs and does
> not start the webcam. i.e i don't see camera light come on
> 
> I can confirm that skype works too after latest round of updates! 
> 
> bug in cheese then for sure?

Maybe, another option is still a video driver issue, as cheese uses Xv where as camorama does not (and I've no idea what skype does). Can you give cheese a shot in fallback mode?
Comment 14 Ravishankar Srinivasan 2012-04-30 04:15:44 EDT
Hans,

Same result for cheese in fallback mode. hangs when run from dock and same warnings as comment #11 when run from terminal. Is the beta rpm built with debug on. anyway to debug it?
Comment 15 Hans de Goede 2012-04-30 07:07:00 EDT
Hi,

Can you please do the following from a terminal:
export LIBV4L2_LOG_FILENAME=/tmp/log
And then start cheese from the same terminal, and after cheese hangs attach /tmp/log here?

Thanks,

Hans
Comment 16 Ravishankar Srinivasan 2012-04-30 07:15:57 EDT
Created attachment 581170 [details]
libv4l log when cheese is starting

libv4l debug log msgs when cheese is starting
Comment 17 Ravishankar Srinivasan 2012-04-30 07:16:54 EDT
debug log attached. when i run cheese from the terminal, it does not come up at all i.e i do not see the app window. just warning msgs printed to the console.
Comment 18 Hans de Goede 2012-04-30 11:48:54 EDT
Hmm, the log is somewhat interesting. During framerate enumeration the camera returns the same framerate multiple times, which may trip up gstreamer or some such. Can you try booting your F-17 with an F-16 kernel (ie the one from comment 3) and retry to run cheese with that config, and then mail me a log file from that attempt?
Comment 19 Ravishankar Srinivasan 2012-05-07 06:29:14 EDT
One more data point. My other Thinkpad T520's webcam works fine. so probably kernel, cheese and uvcvideo are out and the radeon driver could be the culprit.
Comment 20 Richard Chan 2012-05-22 20:17:48 EDT
Created attachment 586219 [details]
dmesg - cheese on a 15s delay

on this system cheese appears after 10-15s
Comment 21 Richard Chan 2012-05-22 20:20:44 EDT
Another data point: I have a similar problem but cheese starts after a 15s delay.

It is a radeon based system as well.
Comment 22 Richard Chan 2012-05-22 20:21:27 EDT
Created attachment 586220 [details]
dmidecode - cheese on 15s delay
Comment 23 Richard Chan 2012-05-22 20:22:06 EDT
Created attachment 586221 [details]
libv4l log - cheese on 15s delay
Comment 24 Richard Chan 2012-05-22 20:32:00 EDT
Mistimed in my earlier comment - the delay until the cheese window pops up is
on the order or 40s

There is a long pause after:

request == VIDIOC_ENUM_FRAMESIZES
  index: 24 pixelformat: RGB3
  1600x1200
result == -1 (Invalid argument)

<pause of about 20-30s>

then 
request == VIDIOC_G_FMT
  pixelformat: MJPG 1280x720
  field: 1 bytesperline: 0 imagesize1843200
  colorspace: 8, priv: 0
result == 0
VIDIOC_S_FMT app requesting: YU12
VIDIOC_S_FMT converting from: MJPG
request == VIDIOC_S_FMT
  pixelformat: YU12 1280x720
  field: 1 bytesperline: 1280 imagesize1382400
  colorspace: 8, priv: 0
result == 0
request == VIDIOC_G_PARM
timeperframe: 1/30
result == 0
request == VIDIOC_S_PARM
timeperframe: 1/30
result == 0
request == VIDIOC_REQBUFS
  count: 2 type: 1 memory: 1
result == 0
request == VIDIOC_QUERYBUF
result == 0
libv4l2: Fake (conversion) mmap buf 0, seen by app at: 0x7fe8ece69000
request == VIDIOC_QUERYBUF
result == 0
libv4l2: Fake (conversion) mmap buf 1, seen by app at: 0x7fe8ede69000
libv4l2: mapped buffer 0 at 0x7fe8ecca7000
libv4l2: mapped buffer 1 at 0x7fe8ecae5000
request == VIDIOC_QBUF
result == 0
request == VIDIOC_QBUF
result == 0
request == VIDIOC_STREAMON
result == 0
Comment 25 Alan Eliasen 2012-05-30 04:12:12 EDT
I had this same problem after installing Fedora 17 (and upgrading all packages.)

I fixed it by removing the cheese package and reinstalling it (I don't know why this worked; it didn't bring in or remove any other dependencies and apparently reinstalled the exact same version.)

# yum remove cheese
# yum install cheese
Comment 26 donjoe 2012-06-03 04:37:11 EDT
I can confirm this bug on Lenovo x121e.

- webcam works fine in skype & camorama
- cheese hangs on startup
- when started from command line, even the main window does not appear

I'm also willing to provide any additional info that might help to resolve this.
Comment 27 Kevin R. Page 2012-06-03 10:47:10 EDT
Another confirmation with Fedora 17 on Lenovo x121e, as per comment #17. Upgraded from F16, though don't remember actually trying the webcam during the week or two it was installed.
Comment 28 Richard Chan 2012-06-06 07:36:49 EDT
Upgraded to 3.3.7 kernel and 3.4.2 cheese from koji; problem persists:r cheese starts after a delay of 45s.

For those of you where it looks like it hangs, you might want to grab a coffee and see if the cheese window appears fter 1 min.

shell> cheese
## pause of 40s - 1min

## cheese main window appears
Comment 29 Hans de Goede 2012-06-06 09:51:47 EDT
I've managed to borrow the x121e from a friend of mine for a while and managed to reproduce the issue *on that laptop*, an update fixing that issue is on its way. This may or may not also help with the problems reported in this bug report with different model laptops.
Comment 30 Hans de Goede 2012-06-06 09:54:29 EDT
Note I've also done a new cheese build fixing some (likely) unrelated issues. When testing please get both the updated cheese and the updated gstreamer-plugins-good. Download the rpms for your architecture here (for cheese you also need to download cheese-libs):
http://koji.fedoraproject.org/koji/buildinfo?buildID=322301
http://koji.fedoraproject.org/koji/buildinfo?buildID=322308

And then run as root:
rpm -Uvh *.rpm
Comment 31 Fedora Update System 2012-06-06 09:57:01 EDT
gstreamer-plugins-good-0.10.31-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gstreamer-plugins-good-0.10.31-2.fc17
Comment 32 Richard Chan 2012-06-06 20:26:35 EDT
New data point:

Updated to above fixes:

1. No segfault
2. No GTK warnings
3. Still 40s until main cheese window appears

$ uname -a
Linux XXXX 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21 22:32:19 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ rpm -qi cheese
Name        : cheese
Epoch       : 2
Version     : 3.4.2
Release     : 2.fc17

$ rpm -qi gstreamer-plugins-good
Name        : gstreamer-plugins-good
Version     : 0.10.31
Release     : 2.fc17
Comment 33 donjoe 2012-06-07 11:54:05 EDT
(In reply to comment #30)
> Note I've also done a new cheese build fixing some (likely) unrelated
> issues. When testing please get both the updated cheese and the updated
> gstreamer-plugins-good. Download the rpms for your architecture here (for
> cheese you also need to download cheese-libs):
> http://koji.fedoraproject.org/koji/buildinfo?buildID=322301
> http://koji.fedoraproject.org/koji/buildinfo?buildID=322308
> 
> And then run as root:
> rpm -Uvh *.rpm

For me these packages fix the issue. 

Thanks.
Comment 34 Fedora Update System 2012-06-07 19:05:14 EDT
Package gstreamer-plugins-good-0.10.31-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gstreamer-plugins-good-0.10.31-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9059/gstreamer-plugins-good-0.10.31-2.fc17
then log in and leave karma (feedback).
Comment 35 Hans de Goede 2012-06-08 08:46:36 EDT
As you all have noticed, I've been working a lot on fixing cheese / gstreamer bugs the last few days, unfortunately the various bugs about cheese all contain comments about various different issues,
so in order to sort things out, I'm going to update the summary of various bugs, to make clear
which bug is about what.

Pease only add comments to bugs if the bug matches the problem you are having! If none of the below bugs match your issue, please file a new bug!

Here is a list of all bugs I'm actively working on, or which are on my todo list:

bug 797188   10-90 seconds delay before showing video
bug 810429   Cheese crashes on machines with radio/tv devices
bug 815134   Cheese not working with webcam on Thinkpad x120e / x121e
bug 815581   Could not map/get buffers from device '/dev/video0' errors when trying to record
bug 820959   Crash when selecting effects, followed by starting recording or switching resolution
bug 829957   Recorded pictures and videos do not appear in area at bottom of Cheese window
bug 830166   Long starup delay when 0 sized filed exist under Videos/Webcam
Comment 36 Kevin R. Page 2012-06-08 09:58:31 EDT
Using cheese{-libs}-3.4.2-2.fc17 and gstreamer-plugins-good-0.10.31-2.fc17 from updates-testing fixes the problem for me on a Thinkpad X121e.

Many thanks for your efforts Hans.
Comment 37 Fedora Update System 2012-06-08 17:11:14 EDT
gstreamer-plugins-bad-free-0.10.23-6.fc17,gstreamer-plugins-good-0.10.31-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gstreamer-plugins-bad-free-0.10.23-6.fc17,gstreamer-plugins-good-0.10.31-3.fc17
Comment 38 Fedora Update System 2012-06-10 19:57:23 EDT
gstreamer-plugins-bad-free-0.10.23-6.fc17, gstreamer-plugins-good-0.10.31-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 39 Fedora Update System 2012-06-11 08:15:45 EDT
gstreamer-plugins-good-0.10.31-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gstreamer-plugins-good-0.10.31-4.fc17
Comment 40 Frank 2012-06-22 05:54:14 EDT
Hi,

i have the same issue on Samsung N145 Plus netbook.
F16 worked fine.
Upgraded to F17 using preupgrade. Everytime i start cheese, camorama the system freezes. I loose any response locally and remotely. Meaning if i am ssh to the netbook i will loose network connection.
I tried things suggested by this thread.

Architecture i686

cheese-3.4.2-2
camorama-0.19-7
gstreamer-plugins-good-0.10.31-4

dmesg:
[   17.312353] Linux video capture interface: v2.00
[   17.322678] uvcvideo: Found UVC 1.00 device WebCam SCB-0355N (2232:1006)
[   17.324482] input: WebCam SCB-0355N as /devices/pci0000:00/0000:00:1d.7/usb1/
1-8/1-8:1.0/input/input8
[   17.324793] usbcore: registered new interface driver uvcvideo
[   17.324801] USB Video Class driver (1.1.1)


System freezes as well in Skype-4.0.0.7 as soon as i touch video, eg. Options -> Video settings

Do i need to open a new bug?

Thanks
Frank
Comment 41 Hans de Goede 2012-06-22 06:06:54 EDT
(In reply to comment #40)
> Hi,
> 
> i have the same issue on Samsung N145 Plus netbook.
> F16 worked fine.
> Upgraded to F17 using preupgrade. Everytime i start cheese, camorama the
> system freezes. I loose any response locally and remotely. Meaning if i am
> ssh to the netbook i will loose network connection.
> I tried things suggested by this thread.

If the entire system freezes, and not just cheese, camorama or skype, crashes or misbehaves,
then yes you need to file a new bug, against the kernel. Can you also try playing a video
in totem, and see if that freezes things too? In that case it could also be an xorg issue.

If it is just cheese freezing, then first of all make sure you've the latest of all relevant packages, do:
yum update --enablerepo=updates-testing cheese gstreamer-*

After this you should have:
cheese-3.4.2-3.fc17
gstreamer-plugins-bad-free-0.10.23-7.fc17
gstreamer-plugins-good-0.10.31-4.fc17

If you then still have issues, please file a new bug against cheese, and try to explain your issues in as much detail as possible.
Comment 42 Frank 2012-06-25 04:43:14 EDT
Thank you for the reply. Unfortunatelly even the latest updates didnt fix the problem. I will file a new bug as per your suggestions.

Thanks
Frank

Note You need to log in before you can comment on or make changes to this bug.