Bug 835151 - configure errors after upgrade
configure errors after upgrade
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Steve Linabery
Giulio Fidente
: ZStream
Depends On:
Blocks: 835973
  Show dependency treegraph
 
Reported: 2012-06-25 12:57 EDT by Dave Johnson
Modified: 2012-12-04 10:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Adding a new provider with aeolus-configure to an existing Cloud Engine environment caused an admin creation error. This bug fix checks if an admin user already exists in a Cloud Engine environment before attempting to create one. The error no longer appears when adding a new provider with aeolus-configure.
Story Points: ---
Clone Of:
: 835973 (view as bug list)
Environment:
Last Closed: 2012-12-04 10:12:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
athomas: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-06-25 12:57:16 EDT
Description of problem:
===================================
Ran aeolus-configure -p vsphere after upgrading system that was configure for ec2 and rhevm...  errors occurred.  Vsphere provider was added... and a account could manually be added as well.

notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: User already exists: admin
err: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: change from notrun to 0 failed: /usr/bin/rake dc:create_user[admin,password,root@localhost.localdomain,Administrator,] returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/conductor/site_admin.pp:9
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Dependency Exec[create_site_admin_user] has failures: true
warning: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Skipping because of failed dependencies
notice: /File[/var/lib/aeolus-conductor/production.admin]: Dependency Exec[create_site_admin_user] has failures: true
warning: /File[/var/lib/aeolus-conductor/production.admin]: Skipping because of failed dependencies


Version-Release number of selected component (if applicable):
aeolus-configure-2.5.9-1.el6cf.noarch


How reproducible:


Steps to Reproduce:
1.   install v1.0.0
2.   configure for ec2 and rhevm
3.   upgrade with yum update
4.   configure for vsphere
  
Actual results:
errors

Expected results:
no errors


Additional info:
provider was successfully added and allows accounts to be associated
Comment 2 Steve Linabery 2012-06-27 13:36:19 EDT
Fix is in:
d9b6c240200169a92cec324f9eb8607389fb0873 conductor
b0dbd98d365bc2aa9af5c8d4b10c3b5ba61c12fb aeolus-configure
Comment 4 Giulio Fidente 2012-10-25 11:39:27 EDT
the error is now different, but this is failing again with aeolus-configure-2.8.9-1.el6cf

notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Login[temporary-administrative-user-aadbae7628e273429336b44dae4912065d05798688a10471]/Web_request[temporary-administrative-user-aadbae7628e273429336b44dae4912065d05798688a10471-conductor-login]/post: post changed '' to 'https://localhost/conductor/user_session'

notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Login[temporary-administrative-user-aadbae7628e273429336b44dae4912065d05798688a10471]/Exec[decrement_login_counter]/returns: executed successfully

notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Hwp[small-x86_64]/Web_request[hwp-small-x86_64]/post: post changed '' to 'https://localhost/conductor/hardware_profiles'

err: /Stage[main]/Aeolus::Profiles::Vsphere/Aeolus::Profiles::Vsphere::Instance[default]/Aeolus::Conductor::Provider[vsphere-default]/Web_request[provider-vsphere-default]/post: change from  to https://localhost/conductor/providers.xml 
failed: An exception was raised when invoking web request: Invalid HTTP Return Code: 422,
                               was expecting one of 200
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Logout[temporary-administrative-user-aadbae7628e273429336b44dae4912065d05798688a10471]/Web_request[temporary-administrative-user-aadbae7628e273429336b44dae4912065d05798688a10471-conductor-logout]: Dependency Web_request[provider-vsphere-default] has failures: true
Comment 5 Steve Linabery 2012-10-25 15:16:32 EDT
This new error is fixed by the fix for bz# 869480 which is in aeolus-configure-2.8.10-1, which is not part of a puddle yet. Not sure what the way forward is on this bug, but the new error is documented in 869480. Switching this back to ON_QA since the original error behaviour is still addressed by the fixes in Comment 2.
Comment 6 Giulio Fidente 2012-10-26 04:37:11 EDT
hi Steve, I understand your point but I'm not sure this new one is the same error also reported in bug 869480, that fix only seem to change the expected return code from 200 to 201 but we're seeing a 422 here
Comment 7 Steve Linabery 2012-10-26 14:39:55 EDT
yikes, my mistake. I missed the '422'.
Comment 8 Steve Linabery 2012-10-30 10:38:15 EDT
I tested 'aeolus-configure -p vsphere' with

[root@virtlab31 ~]# rpm -qa | grep aeolus
aeolus-conductor-daemons-0.13.22-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.13.22-1.el6cf.noarch
aeolus-configure-2.8.11-1.el6cf.noarch
aeolus-all-0.13.22-1.el6cf.noarch
aeolus-conductor-0.13.22-1.el6cf.noarch
rubygem-aeolus-cli-0.7.7-1.el6cf.noarch

(the rpms from the latest puddle as of now)

and I get no errors. Please advise.
Comment 9 Dave Johnson 2012-11-02 14:15:32 EDT
upgrade from v1.0.0 to v1.1 looks good

aeolus-all-0.13.24-1.el6cf.noarch
aeolus-conductor-0.13.24-1.el6cf.noarch
aeolus-conductor-daemons-0.13.24-1.el6cf.noarch
aeolus-conductor-doc-0.13.24-1.el6cf.noarch
aeolus-configure-2.8.11-1.el6cf.noarch
rubygem-aeolus-cli-0.7.7-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 11 errata-xmlrpc 2012-12-04 10:12:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.