This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 835336 - gluster nfs fails to launch vmware esxi VMs
gluster nfs fails to launch vmware esxi VMs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vivek Agarwal
SATHEESARAN
:
: 836005 (view as bug list)
Depends On:
Blocks: 966180
  Show dependency treegraph
 
Reported: 2012-06-25 22:48 EDT by Anand Avati
Modified: 2016-02-17 19:02 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 966180 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:29:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nfs.log file showing "unable to resolve FH errors" (4.42 KB, text/x-log)
2013-04-18 09:01 EDT, Paul Cuzner
no flags Details

  None (edit)
Description Anand Avati 2012-06-25 22:48:23 EDT
Excerpt from the thread:
 http://lists.gnu.org/archive/html/gluster-devel/2012-06/msg00052.html


Are these intended ?:
- hashcount value of 'bar'(0) is not same as 'foo/..'(2) and,
- hashcount value of 'foo'(1) is not same as 'foo/../foo'(3).


# tshark -i 1 -R nfs
Running as user "root" and group "root". This could be dangerous.
Capturing on eth0
 2.386732 192.168.1.23 -> 192.168.1.132 NFS V3 GETATTR Call, FH:0x43976ad5
 2.387772 192.168.1.132 -> 192.168.1.23 NFS V3 GETATTR Reply (Call In 7)  Directory mode:0755 uid:0 gid:0
 3.666252 192.168.1.23 -> 192.168.1.132 NFS V3 GETATTR Call, FH:0x43976ad5
 3.667112 192.168.1.132 -> 192.168.1.23 NFS V3 GETATTR Reply (Call In 17)  Directory mode:0755 uid:0 gid:0
 3.667260 192.168.1.23 -> 192.168.1.132 NFS V3 LOOKUP Call, DH:0x43976ad5/foo                  /* bar/foo */
 3.668321 192.168.1.132 -> 192.168.1.23 NFS V3 LOOKUP Reply (Call In 19), FH:0x3f9fd887
 11.386638 192.168.1.23 -> 192.168.1.132 NFS V3 GETATTR Call, FH:0x43976ad5
 11.387664 192.168.1.132 -> 192.168.1.23 NFS V3 GETATTR Reply (Call In 52)  Directory mode:0755 uid:0 gid:0
 20.386438 192.168.1.23 -> 192.168.1.132 NFS V3 GETATTR Call, FH:0x43976ad5
 20.387436 192.168.1.132 -> 192.168.1.23 NFS V3 GETATTR Reply (Call In 95)  Directory mode:0755 uid:0 gid:0
 29.382531 192.168.1.23 -> 192.168.1.132 NFS V3 GETATTR Call, FH:0x43976ad5
 29.383796 192.168.1.132 -> 192.168.1.23 NFS V3 GETATTR Reply (Call In 126)  Directory mode:0755 uid:0 gid:0
 33.666658 192.168.1.23 -> 192.168.1.132 NFS V3 LOOKUP Call, DH:0x3f9fd887/..                   /* foo/.. */
 33.668097 192.168.1.132 -> 192.168.1.23 NFS V3 LOOKUP Reply (Call In 144), FH:0x42966b36
 33.668310 192.168.1.23 -> 192.168.1.132 NFS V3 READDIRPLUS Call, FH:0x42966b36
 33.669996 192.168.1.132 -> 192.168.1.23 NFS V3 READDIRPLUS Reply (Call In 146) .. foo .
 33.670188 192.168.1.23 -> 192.168.1.132 NFS V3 LOOKUP Call, DH:0x42966b36/..                   /* bar/.. */
 33.671279 192.168.1.132 -> 192.168.1.23 NFS V3 LOOKUP Reply (Call In 148), FH:0xbc1b2900
 33.671425 192.168.1.23 -> 192.168.1.132 NFS V3 LOOKUP Call, DH:0x42966b36/foo                  /* bar/foo */
 33.672421 192.168.1.132 -> 192.168.1.23 NFS V3 LOOKUP Reply (Call In 150), FH:0x3e9ed964
20 packets captured

# egrep "nfs3_log_fh_entry_call|nfs3_log_newfh_res" /var/log/glusterfs/nfs.log | tail -8
[2012-06-25 14:28:40.090333] D [nfs3-helpers.c:1645:nfs3_log_fh_entry_call] 0-nfs-nfsv3: XID: 3d78d872, LOOKUP: args: FH: hashcount 0, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 00000000-0000-0000-0000-000000000001, name: foo                      /* bar/foo */
[2012-06-25 14:28:40.091108] D [nfs3-helpers.c:3462:nfs3_log_newfh_res] 0-nfs-nfsv3: XID: 3d78d872, LOOKUP: NFS: 0(Call completed successfully.), POSIX: 0(Success), FH: hashcount 1, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 7c4b5a51-0108-4ac9-8fd2-4b843dcb2715
[2012-06-25 14:29:10.089791] D [nfs3-helpers.c:1645:nfs3_log_fh_entry_call] 0-nfs-nfsv3: XID: 3d78d879, LOOKUP: args: FH: hashcount 1, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 7c4b5a51-0108-4ac9-8fd2-4b843dcb2715, name: ..                       /* foo/.. */
[2012-06-25 14:29:10.090872] D [nfs3-helpers.c:3462:nfs3_log_newfh_res] 0-nfs-nfsv3: XID: 3d78d879, LOOKUP: NFS: 0(Call completed successfully.), POSIX: 0(Success), FH: hashcount 2, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 00000000-0000-0000-0000-000000000001
[2012-06-25 14:29:10.093266] D [nfs3-helpers.c:1645:nfs3_log_fh_entry_call] 0-nfs-nfsv3: XID: 3d78d87b, LOOKUP: args: FH: hashcount 2, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 00000000-0000-0000-0000-000000000001, name: ..                       /* bar/.. */
[2012-06-25 14:29:10.094056] D [nfs3-helpers.c:3462:nfs3_log_newfh_res] 0-nfs-nfsv3: XID: 3d78d87b, LOOKUP: NFS: 0(Call completed successfully.), POSIX: 0(Success), FH: hashcount 3, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 6edd430d-bc57-470e-8e98-eacfe1a91040
[2012-06-25 14:29:10.094498] D [nfs3-helpers.c:1645:nfs3_log_fh_entry_call] 0-nfs-nfsv3: XID: 3d78d87c, LOOKUP: args: FH: hashcount 2, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 00000000-0000-0000-0000-000000000001, name: foo                      /* bar/foo */
[2012-06-25 14:29:10.095198] D [nfs3-helpers.c:3462:nfs3_log_newfh_res] 0-nfs-nfsv3: XID: 3d78d87c, LOOKUP: NFS: 0(Call completed successfully.), POSIX: 0(Success), FH: hashcount 3, exportid b2d75589-8370-4528-ab4e-b543b3abdc3b, gfid 7c4b5a51-0108-4ac9-8fd2-4b843dcb2715

Regards,

Tomo
Comment 1 Vijay Bellur 2012-07-04 03:18:12 EDT
CHANGE: http://review.gluster.com/3616 (nfs: make NFS filehandles deterministic) merged in master by Anand Avati (avati@redhat.com)
Comment 2 Krishna Srinivas 2012-07-31 06:01:05 EDT
*** Bug 836005 has been marked as a duplicate of this bug. ***
Comment 4 Paul Cuzner 2013-04-18 08:59:28 EDT
I have a customer who are attempting RHS + NFS + VMware and experiencing the same issue - deployment of the VM succeeds but start fails.

It looks like they are on a pre-update4 release (glusterfs-server-3.3.0rhsvirt1-8.el6rhs.x86_64), so I'll get back to them anyway and request that they move to u4.

attaching their nfs.log file (shows errors - Unable to resolve  FH)
Comment 5 Paul Cuzner 2013-04-18 09:01:30 EDT
Created attachment 737304 [details]
nfs.log file showing "unable to resolve FH errors"

Note You need to log in before you can comment on or make changes to this bug.