Bug 835565 - createrepo with --update changes some paths in filelists
createrepo with --update changes some paths in filelists
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: createrepo (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 09:43 EDT by Tomas Mlcoch
Modified: 2014-01-21 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-26 09:10:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (1.10 KB, patch)
2012-11-26 04:28 EST, Tomas Mlcoch
no flags Details | Diff

  None (edit)
Description Tomas Mlcoch 2012-06-26 09:43:02 EDT
Description of problem:
Createrepo with --update option does pointless and useless changes of some paths in filelists.(xml|sqlite)

Version-Release number of selected component (if applicable):
createrepo-0.9.9-11.fc18.noarch.rpm
yum-3.4.3-29.fc18.noarch.rpm
yum-utils-1.1.31-5.fc18.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. mkdir ~/repo && cd ~/repo
2. wget http://fedora.mirrors.tds.net/pub/fedora/releases/17/Fedora/x86_64/os/Packages/f/filesystem-3-2.fc17.x86_64.rpm && wget http://fedora.mirrors.tds.net/pub/fedora/releases/17/Fedora/source/SRPMS/n/nc-1.103-3.fc17.src.rpm
3. createrepo .
   (repodata are fine, every path have only one or none leading slash)
4. createrepo --update .
   (since now, some paths have extra leading slash)
  
Actual results:
Some paths in updated filelists.xml have "//" or "./" as prefix.

Expected results:
All paths are same like before update.

Few lines from filelists.xml:

    filesystem-3-2.fc17.x86_64.rpm package:
    -------------------------------------------
    BEFORE update:
    <file>/bin</file>
    <file>/lib</file>
    <file>/lib64</file>
    <file>/sbin</file>
    <file>/usr/tmp</file>
    <file>/var/mail</file>
    <file type="dir">/</file>
    <file type="dir">/boot</file>

    AFTER update:
    <file>//bin</file>
    <file>//lib</file>
    <file>//lib64</file>
    <file>//sbin</file>
    <file>/usr/tmp</file>
    <file>/var/mail</file>
    <file type="dir">//</file>
    <file type="dir">//boot</file>

    nc-1.103-3.fc17.src.rpm package:
    ------------------------------------
    BEFORE update:
    <file>b64_ntop.c</file>
    <file>nc-1.100-check-accept.patch</file>
    <file>nc-1.100-comma.patch</file>
    <file>nc-1.100-format-size_t.patch</file>
    <file>nc-1.100-initialize-range.patch</file>
    <file>nc-1.100-libbsd.patch</file>
    <file>nc-1.100-pollhup.patch</file>
    <file>nc-1.100-udp-portscan.patch</file>
    <file>nc-1.100-udp-stop.patch</file>
    <file>nc-1.101-linux-ify.patch</file>
    <file>nc-1.103-crlf.patch</file>
    <file>nc-1.103-iptos-class.patch</file>
    <file>nc-1.103.tar.bz2</file>
    <file>nc.spec</file>

    AFTER update:
    <file>./b64_ntop.c</file>
    <file>./nc-1.100-check-accept.patch</file>
    <file>./nc-1.100-comma.patch</file>
    <file>./nc-1.100-format-size_t.patch</file>
    <file>./nc-1.100-initialize-range.patch</file>
    <file>./nc-1.100-libbsd.patch</file>
    <file>./nc-1.100-pollhup.patch</file>
    <file>./nc-1.100-udp-portscan.patch</file>
    <file>./nc-1.100-udp-stop.patch</file>
    <file>./nc-1.101-linux-ify.patch</file>
    <file>./nc-1.103-crlf.patch</file>
    <file>./nc-1.103-iptos-class.patch</file>
    <file>./nc-1.103.tar.bz2</file>
    <file>./nc.spec</file>
Comment 1 Tomas Mlcoch 2012-11-26 04:28:17 EST
Created attachment 651827 [details]
Patch

Patch
Comment 2 Zdeněk Pavlas 2012-11-26 09:10:10 EST
Merged, thanks!

Note You need to log in before you can comment on or make changes to this bug.