Bug 835878 - attempt to create new kickstart profile fails
attempt to create new kickstart profile fails
Status: CLOSED DUPLICATE of bug 817816
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-06-27 08:12 EDT by Mohammed Arafa
Modified: 2012-11-01 12:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 10:08:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2012-06-27 08:12:52 EDT
Description of problem:
i get the below whenever i try to create a new kickstart profile (uploading works tho)

From dev-null@localhost.vm.desktop.us  Tue Jun 26 19:50:44 2012
Return-Path: <dev-null@localhost.vm.desktop.us>
X-Original-To: root@localhost
Delivered-To: root@localhost.vm.desktop.us
From: Spacewalk <dev-null@localhost.vm.desktop.us>
To: root@localhost.vm.desktop.us
Subject: WEB TRACEBACK from spacewalk.vm.desktop.us (6/26/12 7:50:43 PM EDT)
Content-Type: text/plain; charset=UTF-8
Date: Tue, 26 Jun 2012 19:50:43 -0400 (EDT)
Status: RO
X-Keywords:                 
X-UID: 20

The following exception occurred while executing this request:
POST /rhn/kickstart/CreateProfileWizard.do

Date:6/26/12 7:50:43 PM EDT
Headers:
  host: 192.168.1.11
  user-agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,en;q=0.5
  accept-encoding: gzip, deflate
  DNT: 1
  connection: keep-alive
  referer: https://192.168.1.11/rhn/kickstart/CreateProfileWizard.do
  cookie: JSESSIONID=491510960DCCE23309E1222646DC3972; pxt-session-cookie=191x2df8389a2b6a2015b5ddde3189086757
  content-type: application/x-www-form-urlencoded
  content-length: 267

Request:
Local Name = 192.168.1.11
Server Name = 192.168.1.11
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@6b5737a6[session=StandardSession[491510960DCCE23309E1222646DC3972]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.error.status_code, javax.servlet.error.servlet_name, javax.servlet.request.k
ey_size, requestedUri, kickstartCreateWizardForm, javax.servlet.request.ssl_session, org.apache.struts.action.MESSAGE, javax.servlet.error.message, session, javax.servl
et.request.cipher_suite, javax.servlet.error.exception, org.apache.struts.action.mapping.instance, javax.servlet.error.request_uri, org.apache.struts.action.MODULE, 

Form Variables:
  prevStep: second
  rootPasswordConfirm: password
  rootPassword: password
  defaultDownload: true
  virtualizationTypeLabel: qemu
  nextStep: complete
  kickstartLabel: CentOS-62-x86_64_ks
  kstreeId: 1
  userDefinedDownload: 
  submitted: true
  csrf_token: 4339146529177307930
  wizardStep: complete


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:520)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:427)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:228)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:99)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:462)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:91)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at com.opensymphony.sitemesh.webapp.SiteMeshFilter.obtainContent(SiteMeshFilter.java:129)
        at com.opensymphony.sitemesh.webapp.SiteMeshFilter.doFilter(SiteMeshFilter.java:77)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
        at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at com.redhat.rhn.frontend.struts.wizard.WizardStep.invoke(WizardStep.java:116)
        at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.dispatch(RhnWizardAction.java:103)
        at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.execute(RhnWizardAction.java:89)
        at com.redhat.rhn.frontend.action.kickstart.CreateProfileWizardAction.execute(CreateProfileWizardAction.java:104)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:425)
        ... 40 more
Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Double
        at org.cobbler.CobblerConnection.getVersion(CobblerConnection.java:174)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.getCobblerVersion(CobblerXMLRPCHelper.java:123)
        at com.redhat.rhn.manager.kickstart.KickstartFormatter.getFileData(KickstartFormatter.java:252)
        at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:359)
        at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:393)
        at com.redhat.rhn.manager.kickstart.KickstartWizardHelper.store(KickstartWizardHelper.java:189)
        at com.redhat.rhn.domain.kickstart.builder.KickstartBuilder.create(KickstartBuilder.java:545)
        at com.redhat.rhn.frontend.action.kickstart.CreateProfileWizardAction.runComplete(CreateProfileWizardAction.java:283)
        ... 49 more


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jan Pazdziora 2012-06-27 10:08:52 EDT

*** This bug has been marked as a duplicate of bug 817816 ***

Note You need to log in before you can comment on or make changes to this bug.