Bug 836261 - Error message for VM remove, when host non operational, not informative enough
Error message for VM remove, when host non operational, not informative enough
Status: CLOSED DUPLICATE of bug 836263
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 09:57 EDT by Ilanit Stein
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 16:07:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2012-06-28 09:57:57 EDT
Description of problem:

For VM removal in data center with hosts which are non operational,
failure messages are not informative enough:

1) User get error event: "Failed to remove VM <name>"
Can it be more informative? Why does it fail(no up/spm host on data center), or what should be done to allow it's removal (turn hosts to up). 

2) On engine log (attached), error is not so clear or informative on what the root cause is:

2012-06-27 15:37:21,946 ERROR [org.ovirt.engine.core.bll.RemoveVmCommand] (pool-3-thread-48) [6ad336a] Command org.ovirt.engi
ne.core.bll.RemoveVmCommand throw Vdc Bll exception. With error message VdcBLLException: Cannot allocate IRS server
2012-06-27 15:37:21,951 INFO  [org.ovirt.engine.core.bll.RemoveVmCommand] (pool-3-thread-48) [6ad336a] Command [id=ccc6005d-5
022-48bc-be90-9e910ef29c1c]: Compensating CHANGED_STATUS_ONLY of org.ovirt.engine.core.common.businessentities.VmDynamic; sna
pshot: EntityStatusSnapshot [id=64f0a3ea-2bfa-435a-bd0b-d9e3b39786fb, status=Down].

Version-Release number of selected component (if applicable):

SI7

How reproducible:

always

Steps to Reproduce:
1. Add host with wrong cpu type, in order to have it non-operational 
2. add (iscsi) storage domain
3. add vm (with no disk)
4. try to remove the VM
  
Expected results:

Give user information of actions he should take to be able to remove the VM,
or explain why VM can't be removed.
Comment 1 Itamar Heim 2012-06-28 16:07:37 EDT

*** This bug has been marked as a duplicate of bug 836263 ***

Note You need to log in before you can comment on or make changes to this bug.