Bug 836263 - Error message for VM remove, when host non operational, not informative enough
Error message for VM remove, when host non operational, not informative enough
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Oved Ourfali
Ilanit Stein
virt
:
: 836261 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 10:03 EDT by Ilanit Stein
Modified: 2012-12-04 15:12 EST (History)
11 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
istein: needinfo+


Attachments (Terms of Use)
engine log (to find failure search word IRS at 2012-06-27 15:32:30) (56.81 KB, application/x-gzip)
2012-06-28 10:05 EDT, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2012-06-28 10:03:45 EDT
Description of problem:

For VM removal in data center with hosts which are non operational,
failure messages are not informative enough:

1) User get error event: "Failed to remove VM <name>"
Can it be more informative? Why does it fail(no up/spm host on data center), or what should be done to allow it's removal (turn hosts to up). 

2) On engine log (attached), error is not so clear or informative on what the root cause is:

2012-06-27 15:37:21,946 ERROR [org.ovirt.engine.core.bll.RemoveVmCommand] (pool-3-thread-48) [6ad336a] Command org.ovirt.engi
ne.core.bll.RemoveVmCommand throw Vdc Bll exception. With error message VdcBLLException: Cannot allocate IRS server
2012-06-27 15:37:21,951 INFO  [org.ovirt.engine.core.bll.RemoveVmCommand] (pool-3-thread-48) [6ad336a] Command [id=ccc6005d-5
022-48bc-be90-9e910ef29c1c]: Compensating CHANGED_STATUS_ONLY of org.ovirt.engine.core.common.businessentities.VmDynamic; sna
pshot: EntityStatusSnapshot [id=64f0a3ea-2bfa-435a-bd0b-d9e3b39786fb, status=Down].

Version-Release number of selected component (if applicable):

SI7

How reproducible:

always

Steps to Reproduce:
1. Add host with wrong cpu type, in order to have it non-operational 
2. add (iscsi) storage domain
3. add vm (with no disk)
4. try to remove the VM
  
Expected results:

Give user information of actions he should take to be able to remove the VM,
or explain why VM can't be removed.
Comment 1 Ilanit Stein 2012-06-28 10:05:09 EDT
Created attachment 595030 [details]
engine log (to find failure search word IRS at 2012-06-27 15:32:30)
Comment 2 Itamar Heim 2012-06-28 16:07:37 EDT
*** Bug 836261 has been marked as a duplicate of this bug. ***
Comment 3 Barak 2012-07-15 08:50:28 EDT
The line in the engine log specifically say "Cannot allocate IRS server",

What is not clear ?
Comment 4 Oded Ramraz 2012-07-15 08:54:30 EDT
(In reply to comment #3)
> The line in the engine log specifically say "Cannot allocate IRS server",
> 
> What is not clear ?

We are not using this term ( IRS ) anymore . Most of the messages which are using this term rephrased already .
Comment 5 Ilanit Stein 2012-07-15 09:02:15 EDT
Also, A simple user, who has only the events, see "Failed to remove VM <VM name>",
without explanation on why, or what can be done to overcome this.
Comment 6 Oved Ourfali 2012-07-31 06:41:01 EDT
The problem is that if a VM doesn't have disks, then when requesting to remove it, the canDoAction doesn't test whether the DC is valid. However, it does fail on execution.

Fix will include testing that the DC is valid even when removing VMs without disks.
Comment 8 Oded Ramraz 2012-08-29 03:10:38 EDT
Error while executing action: Cannot remove VM: Storage Domain cannot be accessed.
-Please check that at least one Host is operational and Data Center state is up.

Still not sure why we need to test DC status when VM has no disks 

Verified si15.1

Note You need to log in before you can comment on or make changes to this bug.