Bug 836309 - [abrt] yumex-3.0.4-1.fc16: codecs.py:352:write:IOError: [Errno 5] Ошибка ввода/вывода
[abrt] yumex-3.0.4-1.fc16: codecs.py:352:write:IOError: [Errno 5] Ошибка ввод...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
abrt_hash:f048d52a4a7004b193353bbb989...
:
: 859490 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 12:30 EDT by dmitrii
Modified: 2012-09-21 13:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 13:28:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (2.95 KB, text/plain)
2012-06-28 12:30 EDT, dmitrii
no flags Details

  None (edit)
Description dmitrii 2012-06-28 12:30:56 EDT
libreport version: 2.0.10
abrt_version:   2.0.7
cmdline:        /usr/bin/python -E /usr/share/yumex/yum_childtask.py 2 True False /etc/yum.conf
event_log:      2012-06-28-20:30:27> Smolt profile successfully saved
executable:     /usr/share/yumex/yum_childtask.py
kernel:         3.1.5-6.fc16.i686
time:           Чт. 22 дек. 2011 20:15:39
uid:            0
username:       root

smolt_data:     Binary file, 3023 bytes

backtrace:
:codecs.py:352:write:IOError: [Errno 5] Ошибка ввода/вывода
:
:Traceback (most recent call last):
:  File "/usr/share/yumex/yum_childtask.py", line 70, in <module>
:    print err, msg
:  File "/usr/lib/python2.7/codecs.py", line 352, in write
:    self.stream.write(data)
:IOError: [Errno 5] Ошибка ввода/вывода
:
:Local variables in innermost frame:
:consumed: 94
:object: u'\u0417\u0430\u0431\u043b\u043e\u043a\u0438\u0440\u043e\u0432\u0430\u043d\u043e /var/run/yum.pid: \u0434\u0440\u0443\u0433\u0430\u044f \u043a\u043e\u043f\u0438\u044f \u0437\u0430\u043f\u0443\u0449\u0435\u043d\u0430 pid 2175.\n \u0414\u0440\u0443\u0433\u043e\u0435 \u043f\u0440\u0438\u043b\u043e\u0436\u0435\u043d\u0438\u0435: PackageKit'
:data: '\xd0\x97\xd0\xb0\xd0\xb1\xd0\xbb\xd0\xbe\xd0\xba\xd0\xb8\xd1\x80\xd0\xbe\xd0\xb2\xd0\xb0\xd0\xbd\xd0\xbe /var/run/yum.pid: \xd0\xb4\xd1\x80\xd1\x83\xd0\xb3\xd0\xb0\xd1\x8f \xd0\xba\xd0\xbe\xd0\xbf\xd0\xb8\xd1\x8f \xd0\xb7\xd0\xb0\xd0\xbf\xd1\x83\xd1\x89\xd0\xb5\xd0\xbd\xd0\xb0 pid 2175.\n \xd0\x94\xd1\x80\xd1\x83\xd0\xb3\xd0\xbe\xd0\xb5 \xd0\xbf\xd1\x80\xd0\xb8\xd0\xbb\xd0\xbe\xd0\xb6\xd0\xb5\xd0\xbd\xd0\xb8\xd0\xb5: PackageKit'
:self: <open file '<stdout>', mode 'w' at 0xb76f7078>
Comment 1 dmitrii 2012-06-28 12:30:58 EDT
Created attachment 595087 [details]
File: smolt_data
Comment 2 Tim Lauridsen 2012-09-21 13:20:38 EDT
*** Bug 859490 has been marked as a duplicate of this bug. ***
Comment 3 Tim Lauridsen 2012-09-21 13:28:42 EDT
Nothing I can do about this one, sometimes sys.stdout fails inside python, Sorry :)
I have never seen it myself, but it pop up once in a while.

I have made some better catching of the error, but there is no way to work around it.

Note You need to log in before you can comment on or make changes to this bug.