Bug 836686 - multiarch packages mismatching in version.
multiarch packages mismatching in version.
Status: CLOSED DUPLICATE of bug 832771
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lawrence Lim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 19:36 EDT by Maciej Żenczykowski
Modified: 2014-03-25 21:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-30 04:36:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2012-06-29 19:36:39 EDT
# yum upgrade
Loaded plugins: presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package redhat-lsb.x86_64 0:4.0-11.fc17 will be updated
---> Package redhat-lsb.x86_64 0:4.1-4.fc17 will be an update
--> Processing Dependency: redhat-lsb-printing = 4.1 for package: redhat-lsb-4.1-4.fc17.x86_64
--> Processing Dependency: redhat-lsb-languages = 4.1 for package: redhat-lsb-4.1-4.fc17.x86_64
--> Processing Dependency: redhat-lsb-desktop(x86-64) = 4.1 for package: redhat-lsb-4.1-4.fc17.x86_64
--> Processing Dependency: redhat-lsb-cxx(x86-64) = 4.1 for package: redhat-lsb-4.1-4.fc17.x86_64
--> Processing Dependency: redhat-lsb-core(x86-64) = 4.1 for package: redhat-lsb-4.1-4.fc17.x86_64
--> Running transaction check
---> Package redhat-lsb-core.x86_64 0:4.1-4.fc17 will be installed
--> Processing Dependency: redhat-lsb-submod-security(x86-64) = 4.1 for package: redhat-lsb-core-4.1-4.fc17.x86_64
---> Package redhat-lsb-cxx.x86_64 0:4.1-4.fc17 will be installed
---> Package redhat-lsb-desktop.x86_64 0:4.1-4.fc17 will be installed
--> Processing Dependency: redhat-lsb-submod-multimedia(x86-64) = 4.1 for package: redhat-lsb-desktop-4.1-4.fc17.x86_64
---> Package redhat-lsb-languages.x86_64 0:4.1-4.fc17 will be installed
---> Package redhat-lsb-printing.x86_64 0:4.1-4.fc17 will be installed
--> Running transaction check
---> Package redhat-lsb-submod-multimedia.x86_64 0:4.1-4.fc17 will be installed
---> Package redhat-lsb-submod-security.x86_64 0:4.1-4.fc17 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: redhat-lsb-4.1-4.fc17.x86_64 != redhat-lsb-4.0-11.fc17.i686

Uninstalling redhat-lsb-4.0-11.fc17.i686 allows the upgrade to go through.

But clearly the wrong i686 package is in the repos.

# yum list redhat-lsb
Loaded plugins: presto, refresh-packagekit
Installed Packages
redhat-lsb.x86_64                                   4.1-4.fc17                                     @updates
Available Packages
redhat-lsb.i686                                     4.0-11.fc17                                    fedora  

Those two versions should clearly match.
The redhat-lsb-4.1-4.fc17.i686 packages should be pushed to x86_64 updates.

Could someone add some presubmit test to enforce such things?
This isn't the first time such multi-arch package level mismatches have happened in the fedora x86_64 repos.
Comment 1 Parag Nemade 2012-06-30 04:36:03 EDT

*** This bug has been marked as a duplicate of bug 832771 ***

Note You need to log in before you can comment on or make changes to this bug.