Bug 832771 - redhat-lsb.i686 missing for x86_64 due to new subpackages
redhat-lsb.i686 missing for x86_64 due to new subpackages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xibo Ning
Fedora Extras Quality Assurance
:
: 834455 836686 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 05:55 EDT by Michael Schwendt
Modified: 2012-07-17 15:09 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 13:23:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of repos my system uses (7.99 KB, text/plain)
2012-07-12 13:01 EDT, Jonathan Ryshpan
no flags Details

  None (edit)
Description Michael Schwendt 2012-06-17 05:55:29 EDT
Description of problem: For the update, redhat-lsb.i686 is not available for x86_64, which results in a "protected multilib version" update error for users who have both redhat-lsb.i686 and redhat-lsb.x86_64 installed:
https://fedorahosted.org/rel-eng/ticket/5220

It seems this is due to the new subpackages that moved /lib64/ld-lsb-x86-64.so.3 from redhat-lsb to the redhat-lsb-core subpackage. That one now is pulled in by the multiarch package resolver, whereas redhat-lsb no longer is. Library packages are considered by the multiarch repo compose process, if memory serves correctly.
Comment 1 Nadav Har'El 2012-06-20 16:09:29 EDT
I had the same problem: I could no longer "yum update" my x86_64 Fedora 17 system, because it always ended in the same "protected multilib version" error, and therefore wouldn't update the system.

This is definitely a bug, because clueless users (and even most experienced users) will be unable to solve this problem unless the repository is fixed, but I was nevertheless curious to investigate why it happened to me and not to 100% of the Fedora 17 users (I guess if it happened to 100% of the users, it would have been fixed long ago).

It turns out that a long time ago I installed Google's Picasa RPM, and that has a dependency on redhat-lsb.i686, and this is the *only* reason I have this package on my system (as "yum remove redhat-lsb.i686" told me). Since clearly picassa doesn't *really* depends on this package, I went ahead and removed his unnecessary package: "rpm -e --nodeps redhat-lsb.i686". Picasa still works, and "yum update" is back to normal.

I'm guessing that most x86_64 users who never installed Picasa would not have redhat-lsb.i686 which is why they don't encounter this problem. But it's still (very) important for those who do have this package.
Comment 2 Jonathan Ryshpan 2012-06-28 15:27:28 EDT
(In reply to comment #1)
> ...
> It turns out that a long time ago I installed Google's Picasa RPM, and that
> has a dependency on redhat-lsb.i686, and this is the *only* reason I have
> this package on my system (as "yum remove redhat-lsb.i686" told me)...

Google-earth lists redhat-lsb.i686 as a dependancy and won't run unless it is installed (redhat-lsb.x86_64 is not enough).
Comment 3 Parag Nemade 2012-06-30 03:50:46 EDT
*** Bug 834455 has been marked as a duplicate of this bug. ***
Comment 4 Parag Nemade 2012-06-30 04:36:03 EDT
*** Bug 836686 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-07-02 10:57:36 EDT
redhat-lsb-4.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/redhat-lsb-4.1-5.fc17
Comment 6 Fedora Update System 2012-07-02 18:33:43 EDT
Package redhat-lsb-4.1-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redhat-lsb-4.1-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10194/redhat-lsb-4.1-5.fc17
then log in and leave karma (feedback).
Comment 7 Jonathan Ryshpan 2012-07-12 12:05:37 EDT
(In reply to comment #6)
> Package redhat-lsb-4.1-5.fc17:
> * should fix your issue,
> * was pushed to the Fedora 17 testing repository,
> * should be available at your local mirror within two days.

This has not yet appeared on my local mirror, which is accessed via the mirror list: https://mirrors.fedoraproject.org/publiclist/Fedora/17/x86_64/ .  Any idea what's holding it up?
Comment 8 Michael Schwendt 2012-07-12 12:28:53 EDT
What mirror do you use?  yum -d 255 repolist
Comment 10 Jonathan Ryshpan 2012-07-12 13:01:14 EDT
Created attachment 597854 [details]
List of repos my system uses

See my comment to comment #8.
Comment 11 Jonathan Ryshpan 2012-07-12 13:03:55 EDT
(In reply to comment #8)
> What mirror do you use?  yum -d 255 repolist
See attached file: repos.txt
Comment 12 Jonathan Ryshpan 2012-07-12 13:05:56 EDT
(In reply to comment #9)
> the master site is working fine
> http://dl.fedoraproject.org/pub/fedora/linux/updates/testing/17/x86_64/
> 
> Mirrors where I can see this package
> http://mirror.itc.virginia.edu/fedora/updates/testing/17/x86_64/
> http://mirror.uoregon.edu/fedora/linux/updates/testing/17/x86_64/

It is just as you write.  Nevertheless yum on my system does not see them.  I will download and update by hand.
Comment 13 Jonathan Ryshpan 2012-07-12 13:12:00 EDT
I wrote too quick.  These are **testing** repos.  When will these appear in updates.  Redhat-lsb brings in a lot of dependancies, and I am a little afraid to update a lot of stuff on my one system from the testing repos.
Comment 14 Parag Nemade 2012-07-12 23:05:59 EDT
The update has already passed 7 days successfully but I am still buying some more time. I will request to push this update to stable by Monday 16th.

Thanks Michael for testing this update.
Comment 15 Fedora Update System 2012-07-17 13:23:29 EDT
redhat-lsb-4.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Jonathan Ryshpan 2012-07-17 15:09:16 EDT
(In reply to comment #15)
> redhat-lsb-4.1-5.fc17 has been pushed to the Fedora 17 stable repository. 
> If problems still persist, please make note of it in this bug report.

On my system everything is working fine.  No problems with updates and Google Earth (the only application that I know depends on this) is running properly.

Note You need to log in before you can comment on or make changes to this bug.