Bug 836907 - Mobile Broadband disappears in kernel-3.4.4-3
Mobile Broadband disappears in kernel-3.4.4-3
Status: CLOSED DUPLICATE of bug 829880
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 03:08 EDT by Dieter Kasper
Modified: 2012-07-16 08:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 08:44:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of updated RPMs from yesterday (6.18 KB, text/plain)
2012-07-16 03:02 EDT, Dieter Kasper
no flags Details

  None (edit)
Description Dieter Kasper 2012-07-02 03:08:38 EDT
Description of problem:
after updating to kernel-3.4.4-3 the mobile Broadband Device disappeared in the NetworkManager Icon of the gnome desktop. When rebooting with the kernel-3.3.4-5.fc17 everything works well (as it did the last 6 months with fc16)

Version-Release number of selected component (if applicable):
3.4.4-3.fc17.x86_64

How reproducible:
every time when booting with kernel 3.4.4-3.fc17.x86_64

Steps to Reproduce:
1. boot with kernel 3.4.4-3.fc17.x86_64
2.
3.
  
Actual results:
nmcli dev status
DEVICE     TYPE              STATE        
wlan0      802-11-wireless   unavailable  
em1        802-3-ethernet    connected    


Expected results:
DEVICE     TYPE              STATE        
ttyUSB1    gsm               disconnected 
wlan0      802-11-wireless   unavailable  
em1        802-3-ethernet    unavailable  


Additional info:
with kernel-3.4.4-5 active the ttyUSB1 appears under 'wired connections' in the NetworkManager config GUI, whereas with kernel-3.3.4-5.fc17 (as it does under fc16) the ttyUSB1 is configurable under 'Broadband connections'

//var/log/messages with 3.4.4-3
(...)
Jul  2 08:37:38 oder kernel: [    7.522953] USB Serial support registered for Qualcomm USB modem
Jul  2 08:37:38 oder kernel: [    7.532891] qcserial 2-1.6:1.1: Qualcomm USB modem converter detected
Jul  2 08:37:38 oder kernel: [    7.532966] usb 2-1.6: Qualcomm USB modem converter now attached to ttyUSB0
Jul  2 08:37:38 oder kernel: [    7.535716] qcserial 2-1.6:1.3: Qualcomm USB modem converter detected
Jul  2 08:37:38 oder kernel: [    7.535779] usb 2-1.6: Qualcomm USB modem converter now attached to ttyUSB1
(...)
Jul  2 08:37:38 oder modem-manager[892]: <info>  ModemManager (version 0.5.2.0-1.fc17) starting...
Jul  2 08:37:38 oder dbus[860]: [system] Successfully activated service 'org.freedesktop.ModemManager'
Jul  2 08:37:38 oder modem-manager[892]: <info>  Loaded plugin Huawei
(...)
Jul  2 08:37:48 oder dbus-daemon[860]: dbus[860]: [system] Successfully activated service 'net.reactivated.Fprint'
Jul  2 08:37:48 oder dbus-daemon[860]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Jul  2 08:37:48 oder dbus-daemon[860]: ** Message: entering main loop
Jul  2 08:37:48 oder dbus[860]: [system] Successfully activated service 'net.reactivated.Fprint'
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyS0) closing serial port...
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyS0) closing serial port...
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyS0) serial port closed
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyS0) opening serial port...
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyUSB0) closing serial port...
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyUSB0) serial port closed
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyUSB0) opening serial port...
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyUSB1) closing serial port...
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyUSB1) serial port closed
Jul  2 08:37:50 oder modem-manager[892]: <info>  (ttyUSB1) opening serial port...
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyS0) serial port closed
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyS0) opening serial port...
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB0) closing serial port...
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB0) serial port closed
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB0) opening serial port...
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB1) closing serial port...
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB1) serial port closed
Jul  2 08:37:50 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB1) opening serial port...
Jul  2 08:37:53 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB0) closing serial port...
Jul  2 08:37:53 oder modem-manager[892]: <info>  (ttyUSB0) closing serial port...
Jul  2 08:37:53 oder modem-manager[892]: <info>  (ttyUSB0) serial port closed
Jul  2 08:37:53 oder dbus-daemon[860]: modem-manager[892]: <info>  (ttyUSB0) serial port closed



Which additional Infos/Debug do you need?
Comment 1 Josh Boyer 2012-07-05 11:30:30 EDT
Can you attach the full dmesg output for a failing boot?  Also, the output of lsusb would be useful.
Comment 2 Dieter Kasper 2012-07-16 03:02:05 EDT
Created attachment 598379 [details]
list of updated RPMs from yesterday

After upgrading to the latest RPMs yesterday the problem disappeared.
RPMs included in this update:
kernel-3.4.4-5.fc17.x86_64
(...)
see attachment
Comment 3 Dieter Kasper 2012-07-16 03:14:06 EDT
just looked into the changelog for kernel-3.4.4-5 ...


* Thu Jul 05 2012 Josh Boyer <jwboyer@redhat.com>
- Fix device misprobe for Gobi devices (rhbz 829880)

... sounds for me that my problem (rhbz 836907) is a duplicate to #829880

Thanks for the fix!!
Comment 4 Josh Boyer 2012-07-16 08:44:29 EDT

*** This bug has been marked as a duplicate of bug 829880 ***

Note You need to log in before you can comment on or make changes to this bug.