Bug 836935 - RFE: Zanata should show number of messages and not number of words in project stat
RFE: Zanata should show number of messages and not number of words in project...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.0
Assigned To: Alex Eng
Ding-Yi Chen
:
: 731926 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 05:12 EDT by Parag Nemade
Modified: 2012-11-07 01:19 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.8.0-SNAPSHOT (20121003-1138)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 01:19:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2012-07-02 05:12:37 EDT
Description of problem:
Its really annoying to see zanata UI shows number of words instead of number of messages. Please allow the option to show stat either by messages or by words.


Version-Release number of selected component (if applicable):
current zanata server

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
shows language stat by words whereas msgfmt gives stat by messages.

Expected results:
should give language stat by messages

Additional info:
Comment 1 Runa Bhattacharjee 2012-07-02 08:28:05 EDT
What is the zanata version or server that we are looking at here? Thanks.
Comment 2 Parag Nemade 2012-07-02 09:53:00 EDT
zanata-python-client-1.3.5-1.fc17.noarch
zanata python client version: 1.3.5, zanata server API version: 1.5.0
Comment 3 Sean Flanigan 2012-07-03 01:26:21 EDT
I assume this is referring to the stats page and project page, eg https://translate.zanata.org/zanata/project/view/iok/iter/f18/stats
https://translate.zanata.org/zanata/project/view/iok

In the editor, the document list shows words only, but the tooltips cover words and messages.
Comment 4 Parag Nemade 2012-07-03 01:33:28 EDT
First of all its not clear whether maintainer is assumed to subscribe to all the language teams or not? I am only member of Marathi language and when clicked on Translate, I can see what you are saying. Tooltip provides number of messages and words. But that is not what I want.

From the developer point of view, why I need to open each language editor to see number of messages? This information must be shown in a single page at
https://translate.zanata.org/zanata/project/view/iok/iter/f18/stats
Comment 5 Runa Bhattacharjee 2012-07-30 08:44:59 EDT
Technical evaluation requested.
Comment 6 Alex Eng 2012-09-25 19:25:57 EDT
Implemented statistic options in files page as well as in translation workspace.

See https://github.com/zanata/zanata/commit/8b4fa77900db561a1f1dcbb3b1eac19a5ac0d604
https://github.com/zanata/zanata/commit/32d64c0c1780ce30ac0a41dcdd61912768a07645
Comment 7 Alex Eng 2012-09-25 19:26:53 EDT
*** Bug 731926 has been marked as a duplicate of this bug. ***
Comment 8 Ding-Yi Chen 2012-09-26 22:58:09 EDT
Hi Alex,

Since you combine Hedda's and Parag reports, so I will verify this bug according those 2 reports.

Tested with Zanata version 1.8.0-SNAPSHOT (20120927-0027)
1. At language level (Translator's view), it can choose both the "Words" and "Messages". However, it does not provide "Hours", which Hedda wants.

2. At project level (Project maintainer view), it does not provide the option for choosing the statistic view, which I think Parag possibly want.

Thus reassigned.

BTW, do you want to split the bug again as 
Bug 731926 to add "Work Hour" view,
and this one to and a dropdown box for choosing the statistic view?

Regards,
Comment 9 Ding-Yi Chen 2012-09-26 23:03:18 EDT
Hi Parag,

If you need this feature urgently,
The Zanata REST API does support the statics you need. Please see
Bug 831894 for REST API and 
Bug 848988 for Maven client support.
Comment 10 Parag Nemade 2012-09-26 23:09:03 EDT
Thanks dchen for this update. I am not in a hurry as currently I am not doing anything with zanata.
Comment 12 Alex Eng 2012-09-27 23:24:40 EDT
Implemented hours left information in statistic label.

See https://github.com/zanata/zanata/commit/01a42489bcbbc78542ea3a50f6121bf30377744d
Comment 13 Ding-Yi Chen 2012-09-28 02:43:59 EDT
Tested with Zanata version 1.8.0-SNAPSHOT (20120928-1429)

The Statistic can now choose between by "Words" or by "Messages", however
the remaining hours should be the same.

Reassigned.
Comment 14 Alex Eng 2012-10-01 18:28:34 EDT
Confirmed changes has not been deployed to test machine during test. Please retest again.
Comment 15 Ding-Yi Chen 2012-10-02 23:42:19 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20121003-1138)
Comment 16 Sean Flanigan 2012-11-07 01:19:14 EST
Fix released in Zanata 2.0.

Note You need to log in before you can comment on or make changes to this bug.