Bug 837087 - Python3 support
Python3 support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-prettytable (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 837689
  Show dependency treegraph
 
Reported: 2012-07-02 13:48 EDT by Ralph Bean
Modified: 2016-01-04 09:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 13:48:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to update python-prettytable (4.10 KB, patch)
2012-07-02 13:48 EDT, Ralph Bean
no flags Details | Diff

  None (edit)
Description Ralph Bean 2012-07-02 13:48:47 EDT
Created attachment 595787 [details]
Patch to update python-prettytable

There is no python3-prettytable package.  The upstream package already supports python3 out-of-the-box.

I've created and attached a patch against the spec file that fixes this.
My patch also does a number of other things, like running unit tests, modernizing the spec file, and updating to the latest upstream version.

Can you please build and create updates for f17, f16, and epel6?

I'm willing to co-maintain this package and take care of the above if you'd like.
Comment 1 Pádraig Brady 2012-07-02 15:00:01 EDT
Thanks Ralph.
Note the prettytable 0.6 is not backwards compat with 0.5 as it drops
the printt method I think.

Therefore we'll have to be careful and update the openstack clients at least to be compat with the new version, before updating.

I'll add that to my TODO list.
Comment 2 Ralph Bean 2012-07-03 10:59:04 EDT
Thanks Pádraig -- What are the names of the openstack client packages?  I'd like to take a look. :)
Comment 3 Pádraig Brady 2012-07-04 12:43:22 EDT
python-novaclient
python-keystoneclient
python-quantumclient
python-glanceclient
Comment 4 Ralph Bean 2012-07-04 15:18:47 EDT
I just checked and the latest upstream releases for each of those packages all require prettytable>=0.6.0.  An update across the board should do it.
Comment 5 Ralph Bean 2012-09-06 13:48:04 EDT
This seems to be set for F18.  I'm closing the ticket.

Note You need to log in before you can comment on or make changes to this bug.