Bug 837318 - Guest can not be booted from disk first time with etherboot if we select network in bios
Guest can not be booted from disk first time with etherboot if we select netw...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: etherboot (Show other bugs)
5.9
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 08:49 EDT by FuXiangChun
Modified: 2013-11-13 22:43 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 09:28:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first time boot 1 (9.77 KB, image/png)
2012-07-03 08:50 EDT, FuXiangChun
no flags Details
first time boot 2 (9.22 KB, image/png)
2012-07-03 08:51 EDT, FuXiangChun
no flags Details
first time boot 3 (10.66 KB, image/png)
2012-07-03 08:51 EDT, FuXiangChun
no flags Details
twice reboot (9.28 KB, image/png)
2012-07-03 08:52 EDT, FuXiangChun
no flags Details

  None (edit)
Description FuXiangChun 2012-07-03 08:49:30 EDT
Description of problem:
if boot guest with etherboot in boot menu(F12), kvm cann't read Hard disk correctly when the first time boot guest. guest boot successfully after guest will reboot(twice) automatically. 

notes:1. this issue can be reproduced with ethertool version etherboot-zroms-kvm-5.4.4-15.el5 and etherboot-zroms-kvm-5.4.4-16.el5, so it isn't a regression bug.
      2. if use gpxe to boot guest. then can not hit this issue.
 

Version-Release number of selected component (if applicable):
# uname -r
2.6.18-322.el5

#rpm -qa|grep kvm
kvm-83-249.el5

# etherboot version
etherboot-zroms-kvm-5.4.4-15.el5 or etherboot-zroms-kvm-5.4.4-16.el5

How reproducible:
always

Steps to Reproduce:
1.boot guest 
# /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu qemu64,+sse2 -drive file=/home/win2008r2-64.qcow2,format=qcow2,media=disk,if=ide,cache=none,werror=stop,boot=on -net nic,model=virtio,macaddr=00:24:21:7F:B7:F8,vlan=0 -net tap,sndbuf=0,vlan=0,script=/etc/qemu-ifup,downscript=no -uuid 67819171-c8fc-4f01-8933-d38a76c8f20b -spice host=0,ic=on,port=5937,disable-ticketing -qxl 1 -boot nc -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -fda /usr/share/virtio-win/virtio-drivers-1.0.3-52454.vfd -boot nc

2.press F12 and select "Network [virtio-net.zrow 5.4.4 (GPL) ethe]" from boot menu
3.
  
Actual results:
guest cann't boot successfully the first time, it will reboot automatically.

Expected results:
guest boot successful the first time

Additional info:
Comment 1 FuXiangChun 2012-07-03 08:50:41 EDT
Created attachment 595970 [details]
first time boot 1
Comment 2 FuXiangChun 2012-07-03 08:51:10 EDT
Created attachment 595971 [details]
first time boot 2
Comment 3 FuXiangChun 2012-07-03 08:51:43 EDT
Created attachment 595975 [details]
first time boot 3
Comment 4 FuXiangChun 2012-07-03 08:52:36 EDT
Created attachment 595976 [details]
twice reboot
Comment 5 RHEL Product and Program Management 2012-07-03 22:07:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Ronen Hod 2012-07-09 03:59:04 EDT
Closing this bug as it is not a regression, and there is no data corruption, and although not very aesthetic, there is an automatic second boot and it works, and there is a workaround (use gpxe).

Thanks, Ronen.
Comment 7 Sibiao Luo 2012-07-31 02:16:26 EDT
(In reply to comment #6)
> Closing this bug as it is not a regression, and there is no data corruption,
> and although not very aesthetic, there is an automatic second boot and it
> works, and there is a workaround (use gpxe).
> 

Hi Ronen,

   I test the gpxe which also can hit this issue with the lastest gpxe-roms-qemu-0.9.7-9.el5. If i boot guest with gpxe in boot menu(F12), KVM cann't read Hard disk correctly at the first time booting. After guest reboot (the second time) automatically, it can boot from hard disk successfully. Ronen, should i need to open a new bug for tracking this issue? Thx.

host info:
# uname -r && rpm -q kvm
2.6.18-333.el5
kvm-83-258.el5
# rpm -qa | grep  gpxe
gpxe-roms-qemu-0.9.7-9.el5
guest info:
# uname -r
2.6.18-333.el5

Best wish.
sluo
Comment 8 Ronen Hod 2012-08-06 02:13:13 EDT
Following additional info by sluo, reopening for 5.10.
Comment 9 Sibiao Luo 2012-08-06 03:58:54 EDT
Hi all,

   Since etherboot and gpxe are different components, so i separate it into different bugs for tracking, the new bug #845931.

Best wish.
sluo
Comment 12 Ronen Hod 2013-04-17 10:48:50 EDT
Related to BZ#845931
Comment 13 RHEL Product and Program Management 2013-05-01 02:46:51 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.