Bug 837362 - NPE on console
NPE on console
Status: CLOSED WORKSFORME
Product: JBoss Data Grid 6
Classification: JBoss
Component: unspecified (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low
: CR1
: 6.0.1
Assigned To: Tristan Tarrant
Michal Linhard
:
: 851251 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 11:44 EDT by Heiko W. Rupp
Modified: 2014-03-17 00:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 09:18:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
as7 management client performing the erroneous operation (4.22 KB, application/zip)
2012-08-09 08:50 EDT, Michal Linhard
no flags Details

  None (edit)
Description Heiko W. Rupp 2012-07-03 11:44:34 EDT
JBoss ON plugin tries to find resources by "probing" for them - that is it basically sends a :read-resource to /a=b/b=c/.. in the domain management model.

When doing this, the following NPE shows up:

17:27:19,733 ERROR [org.jboss.as.controller.management-operation] (HttpManagementService-threads - 25) JBAS014612: Operation ("read-attribute") fehlgeschlagen - Adresse: ([
    {"subsystem" => "infinispan"},
    {"cache-container" => "local"},
    {"local-cache" => "default"}
]): java.lang.NullPointerException
	at org.jboss.as.clustering.infinispan.subsystem.CacheMetricsHandler.executeRuntimeStep(CacheMetricsHandler.java:156)
	at org.jboss.as.controller.AbstractRuntimeOnlyHandler$1.execute(AbstractRuntimeOnlyHandler.java:90) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:397) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:284) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.completeStep(AbstractOperationContext.java:211) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.controller.ModelControllerImpl$DefaultPrepareStepHandler.execute(ModelControllerImpl.java:473) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:397) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:284) [jboss-as-controller-7.1.
Comment 1 Michal Linhard 2012-08-09 08:50:15 EDT
Created attachment 603252 [details]
as7 management client performing the erroneous operation
Comment 2 Michal Linhard 2012-08-09 08:52:09 EDT
I couldn't reproduce for neither JDG 6.0.0.GA nor JDG 6.0.1.ER1 using the attached code, can you please specify exact operation parameters that cause the NPE ?
Comment 3 mark yarborough 2012-08-15 09:31:40 EDT
IS this a valid bug? Moving from target milestone ER2 to unspecified. Retriage with input from mlinhard and ttarrant on/before 22-Aug.
Comment 4 mark yarborough 2012-08-16 09:02:43 EDT
Ping Heiko for more information on the testing.
Comment 5 Heiko W. Rupp 2012-08-16 10:55:47 EDT
Sorry, I can't recall what I was doing at that time. 
I think looking at the source at the specific address should show if a NPE is possible or not. If not, then this has been fixed and you can just close the issue.
Comment 6 Tristan Tarrant 2012-08-29 09:15:58 EDT
*** Bug 851251 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.