Bug 851251 - NullPointerException in logs while installing rhq management user in JDG (or restarting JDG if rhq user has already been installed)
NullPointerException in logs while installing rhq management user in JDG (or ...
Status: CLOSED DUPLICATE of bug 837362
Product: JBoss Data Grid 6
Classification: JBoss
Component: JON Plugin (Show other bugs)
unspecified
i386 Linux
medium Severity unspecified
: CR1
: 6.0.1
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 11:12 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 09:15:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jdg.log (48.23 KB, text/x-log)
2012-08-23 11:12 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2012-08-23 11:12:57 EDT
Created attachment 606631 [details]
jdg.log

Description of problem:
If both JDG and EAP servers are running on the same machine and both JDG and EAP plugins are installed in JON - JDG server starts throws "NullPointerException"in logs.

Version-Release number of selected component (if applicable):
JON 3.1.1 ER3
JDG plugin version - 6.0.1.ER2
JDG server version - 6.0.0.GA

How reproducible:
always

Steps to Reproduce:
1. Install JON
2. Install both JDG and EAP plugins
3. Start EAP server in standalone mode and inventory in JON
4. Start JDG server and inventory in JON
5. Install rhq user (using Install operaiton)
  
Actual results:
Exceptions in log

Expected results:
all resources for JDG server should be inventoried without exceptions

Additional info:
please get attached fragment from log. should you need to reproduce the case, please ping me.
Comment 1 mark yarborough 2012-08-29 09:04:57 EDT
Tristan thinks this is likely a dup of problem Heiko reported and is already fixed. He will check and close/alreadyfixed if so.
Comment 2 Tristan Tarrant 2012-08-29 09:11:18 EDT
Potentially a dup of https://bugzilla.redhat.com/show_bug.cgi?id=837362

Please test against 6.0.1.ER3 server
Comment 3 Tristan Tarrant 2012-08-29 09:15:58 EDT

*** This bug has been marked as a duplicate of bug 837362 ***

Note You need to log in before you can comment on or make changes to this bug.