Bug 837379 - [abrt] lxpanel-0.5.8-1.fc17: panel_draw_label_text: Process /usr/bin/lxpanel was killed by signal 11 (SIGSEGV)
[abrt] lxpanel-0.5.8-1.fc17: panel_draw_label_text: Process /usr/bin/lxpanel ...
Status: CLOSED DUPLICATE of bug 587430
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:598a4e8dcb6a568937a61c18abe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 12:16 EDT by Moez Roy
Modified: 2013-05-18 13:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 13:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.77 KB, text/plain)
2012-07-03 12:16 EDT, Moez Roy
no flags Details
File: maps (25.87 KB, text/plain)
2012-07-03 12:16 EDT, Moez Roy
no flags Details
File: dso_list (4.73 KB, text/plain)
2012-07-03 12:16 EDT, Moez Roy
no flags Details

  None (edit)
Description Moez Roy 2012-07-03 12:16:40 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        lxpanel --profile LXDE
crash_function: panel_draw_label_text
executable:     /usr/bin/lxpanel
kernel:         3.3.4-5.fc17.x86_64
pid:            978
pwd:            /home/liveuser
smolt_data:     Unable to save UUID to /etc/smolt/hw-uuid.  Please run once as root.
time:           Tue 03 Jul 2012 05:12:53 AM EDT
uid:            1000
username:       liveuser

backtrace:      Text file, 14099 bytes
dso_list:       Text file, 4839 bytes
maps:           Text file, 26486 bytes

build_ids:
:8568e11bef79abaf14513d18a8559282d8dad34a
:54a5cc118d928470da13565de8592b664a9868e0
:647c8183274c4626c81e86e7a631a81782a04e65
:b6d75088f555d197be1476cb1c580640826ae029
:b8bfc491895389962d926fdc99cbfbac571f2cf0
:a8efbe1d263ad42afae74bc027eee88eaa754f55
:f4d479614b09460085428bbe7d53df454d0d39e5
:b277af36744327e3d58eae76bcdaadcca71a28c6
:ef4efc6ecedbd1f7c18170b552d34aa062858634
:a7a90d872ef72df12f4344a1a6fadb184e5c0cc8
:f64b7319b84d426ed547084bdb2577f4f596c18f
:bd0ac043ae8788e4131de24fa2becebf2ba97698
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:faca16f15d87b83d2947a386e319b02f724dcbb5
:253afe744466fe7580bbb6040de6183dba9e2b02
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:42675a8ad8f70ff19362070510cdf1ba202a70db
:127f8958b602715234a02b88adb08afd9e34c203
:657855175bdd1a6a2a52f1b51fd5b8a1afe2efcd
:508cf66f72e70054a41215f80ed2385c6bb80030
:f6d72221cbd08cb36bb88823d33deb2024f2bee3
:7d479fde02ce6cc3d18a5bb1dc60a5a23d3b25ab
:da75545d61709e08c24aae7867c5702fa165b12c
:63651cdc0224824a9c9324c77c3b5887378e871d
:c4ec0971b2dcee71aaf8374975474054245fea00
:2c09a3f87a92231b0acabb79968d235d61c36967
:822e9b3523e8312240f41a25722d539bc77ed436
:67792c148d2b8f13f6732c9367e926c26d7376c5
:73777e822e00ca152ffca281ab0ace0cb498ec48
:404cbecd24d186758ed474b345313da28b2990fa
:3f0991d9a4679b6bdd8a78ab2d05ecf4cc995651
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480
:dec0de92024bee74c75c04bde4c54c097fe68ae8
:ce246b3297de0d233ac2c5f9e50061e2b13a330c
:6e5d5649c704cd3a34cf145ccd2d08994f1e83ff
:4d09d82785dab5f95c01b69bc0785145a5954d30
:7c35310fc506498c612d5d982ab03becc4b4817c
:9ea9b4fd0fc47b9ba19d393e1c1f70959654c6b8
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292
:731b3801f71de6bd888953161b715e6cbda0ab60
:8f7c190397d7c1f617e66f18f759714662b60367
:c24fd7404668fdbb57aec685a0f63cdd8a289d29
:839c8e3a55bd7f61afdcfebeae52f9dadc3a69fb
:4b044fe80e4c1b69986abc4b160c303048005d4e
:c61e487cc8906c4f1bd85b39a4d751b414e423a0
:5dd234206476b0387cd251598aa72a2c95c763c5
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:234d4eb1aa690c38533ef82f517b390255d3bc4d
:247132297f287226a24c12e683292f5c94013066
:5350b5972464f66f404861dc50225a114a2a5e7e

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/liveuser/1

core_backtrace:
:ef4efc6ecedbd1f7c18170b552d34aa062858634 0x19c20 panel_draw_label_text [exe] -
:ef4efc6ecedbd1f7c18170b552d34aa062858634 0x1e53f - [exe] -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x4824b - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x475cc g_main_context_dispatch libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x479e8 - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x47de2 g_main_loop_run libglib-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x149d67 gtk_main libgtk-x11-2.0.so.0 -
:ef4efc6ecedbd1f7c18170b552d34aa062858634 0xf1fd main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:SAL_USE_VCLPLUGIN=gtk
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=lxde-
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:IMSETTINGS_MODULE=none
:USER=liveuser
:initrd=initrd0.img
:DESKTOP_SESSION=LXDE
:PATH=/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/liveuser/.local/bin:/home/liveuser/bin
:MAIL=/var/spool/mail/liveuser
:QT_IM_MODULE=xim
:PWD=/home/liveuser
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:XDG_SEAT=seat0
:HOME=/home/liveuser
:SHLVL=1
:XDG_CONFIG_HOME=/home/liveuser/.config
:BOOT_IMAGE=vmlinuz0
:LOGNAME=liveuser
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-28FsCnmTRO,guid=1816db978711014b520a134900000013
:PREFERRED=/usr/bin/startlxde
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:XDG_RUNTIME_DIR=/run/user/liveuser
:DISPLAY=:0
:GTK_IM_MODULE=gtk-im-context-simple
:XAUTHORITY=/home/liveuser/.Xauthority
:_LXSESSION_PID=817
:XDG_CURRENT_DESKTOP=LXDE

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 28993                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       28993                28993                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/var/log/lxdm.log
:pos:	1254
:flags:	0102001
:2:/home/liveuser/.xsession-errors
:pos:	3684
:flags:	0100001
:3:socket:[15851]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002

var_log_messages:
:Jul  3 05:12:53 localhost kernel: [17350.272088] lxpanel[978]: segfault at 6b00000251 ip 0000000000419c20 sp 00007fff5b0e1330 error 4 in lxpanel[400000+2f000]
:Jul  3 05:12:53 localhost abrt[2652]: Saved core dump of pid 978 (/usr/bin/lxpanel) to /var/spool/abrt/ccpp-2012-07-03-05:12:53-978 (4747264 bytes)

xsession_errors:
:lxpanel: can't load netstat plugin
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:(lxpanel:978): Gtk-CRITICAL **: IA__gtk_widget_set_state: assertion `GTK_IS_WIDGET (widget)' failed
:lxpanel: can't load netstat plugin
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
:lxpanel : X error: BadWindow (invalid Window parameter)
Comment 1 Moez Roy 2012-07-03 12:16:43 EDT
Created attachment 596017 [details]
File: backtrace
Comment 2 Moez Roy 2012-07-03 12:16:44 EDT
Created attachment 596018 [details]
File: maps
Comment 3 Moez Roy 2012-07-03 12:16:46 EDT
Created attachment 596019 [details]
File: dso_list
Comment 4 Asier Gutierrez 2012-11-02 17:47:02 EDT
I just closed the Empathy app from the Panel.

backtrace_rating: 4
Package: lxpanel-0.5.10-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Pavel Roskin 2013-01-17 20:23:17 EST
I just got that on Fedora 18.  I didn't notice anything wrong other than the abrt icon appearing in the tray.  Relevant part of .xsession-errors:

lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)
lxpanel : X error: BadWindow (invalid Window parameter)

** (lxpanel:2264): WARNING **: Group count mismatch, ctrls = 2, groups = 2, symbols = 3
Comment 6 Pavel Roskin 2013-01-24 09:27:31 EST
lxpanel is 0.5.10-3 on Fedora 17 and 0.5.10-2 on Fedora 18.  So it wasn't upgraded by fedup on my system.  Perhaps a new revision should be made for Fedora 18 to make sure users are not reporting a bug in the Fedora 17 package running on Fedora 18.
Comment 7 Christoph Wickert 2013-05-18 13:26:45 EDT

*** This bug has been marked as a duplicate of bug 587430 ***

Note You need to log in before you can comment on or make changes to this bug.