Bug 587430 - [abrt] crash in lxpanel-0.5.5-3.fc13: flash_window_timeout: Process /usr/bin/lxpanel was killed by signal 11 (SIGSEGV)
[abrt] crash in lxpanel-0.5.5-3.fc13: flash_window_timeout: Process /usr/bin/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
https://sourceforge.net/tracker/index...
abrt_hash:1277c01288393dafa02e1b7bd94...
: Reopened
: 578984 587557 596654 596871 596873 600831 603697 609843 610158 611701 618022 619260 620194 622479 622481 626564 645270 645576 647415 650551 656020 663368 667228 677166 679112 682548 706867 718159 767043 799740 802034 824164 830479 837379 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-29 17:39 EDT by Terry Wallwork
Modified: 2013-05-29 22:58 EDT (History)
27 users (show)

See Also:
Fixed In Version: lxpanel-0.5.12-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.68 KB, text/plain)
2010-04-29 17:39 EDT, Terry Wallwork
no flags Details
(complete) fix (933 bytes, patch)
2013-04-22 14:29 EDT, Bastiaan Jacques
no flags Details | Diff

  None (edit)
Description Terry Wallwork 2010-04-29 17:39:24 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: lxpanel --profile LXDE
comment: crashed when closing pidgen
component: lxpanel
executable: /usr/bin/lxpanel
global_uuid: 1277c01288393dafa02e1b7bd942aa2b699922d7
kernel: 2.6.32.11-99.fc12.i686
package: lxpanel-0.5.5-3.fc12
rating: 4
reason: Process /usr/bin/lxpanel was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 Terry Wallwork 2010-04-29 17:39:27 EDT
Created attachment 410237 [details]
File: backtrace
Comment 2 Christoph Wickert 2010-04-29 18:35:03 EDT
*** Bug 578984 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Wickert 2010-04-29 18:36:08 EDT
Thanks for your bug report. I fact I have been waiting for a backtrace of this crash.
Comment 4 Christoph Wickert 2010-04-30 06:03:20 EDT
*** Bug 587557 has been marked as a duplicate of this bug. ***
Comment 5 Terry Wallwork 2010-05-09 03:55:18 EDT
Package: lxpanel-0.5.5-3.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1.Close down pidgin
2.
3.


Comment
-----
Closed down pidgin from the lxpanel sys tray area
Comment 6 Christoph Wickert 2010-05-27 05:51:05 EDT
*** Bug 596654 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Wickert 2010-05-27 13:07:24 EDT
*** Bug 596873 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Wickert 2010-05-27 13:07:34 EDT
*** Bug 596871 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Wickert 2010-06-14 16:26:43 EDT
*** Bug 603697 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Wickert 2010-07-01 06:19:09 EDT
*** Bug 609843 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Wickert 2010-07-01 19:24:48 EDT
*** Bug 610158 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Wickert 2010-07-06 04:41:47 EDT
*** Bug 611701 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Wickert 2010-07-16 08:42:05 EDT
Thanks everybody for their bug reports. I forwarded them upstream as https://sourceforge.net/tracker/?func=detail&aid=3030520&group_id=180858&atid=894869

Feel free to add yourself to the upstream bug report in order to follow any changes. Even if you don't, will be notified once this bug is resolved in Fedora. If I need more information, I will get back to you.

I'm now closing the bug UPSTREAM because this is where further investigation should take place.
Comment 14 Christoph Wickert 2010-07-16 09:08:45 EDT
*** Bug 600831 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Wickert 2010-07-25 13:27:44 EDT
*** Bug 618022 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Wickert 2010-07-29 03:32:54 EDT
*** Bug 619260 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2010-07-30 18:24:53 EDT
lxpanel-0.5.6-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lxpanel-0.5.6-1.fc13
Comment 18 Christoph Wickert 2010-08-01 10:06:29 EDT
*** Bug 620194 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Wickert 2010-08-01 10:07:28 EDT
Guys, please test the update and provide feeback at
http://admin.fedoraproject.org/updates/lxpanel-0.5.6-1.fc13
Comment 20 Onur Samiloglu 2010-08-05 02:01:48 EDT
Seems to be resolved here.
Comment 21 Christoph Wickert 2010-08-09 10:16:57 EDT
*** Bug 622479 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Wickert 2010-08-09 10:17:06 EDT
*** Bug 622481 has been marked as a duplicate of this bug. ***
Comment 23 Onur Samiloglu 2010-08-09 10:32:30 EDT
Problem is reproduced two more times since the last update. I'll look into getting a new dump.
Comment 24 Christoph Wickert 2010-08-10 06:23:28 EDT
*** Bug 621868 has been marked as a duplicate of this bug. ***
Comment 25 Fedora Update System 2010-08-19 22:01:32 EDT
lxpanel-0.5.6-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Christoph Wickert 2010-08-27 17:55:16 EDT
The crash is back in 0.5.6 and will be tracked in https://sourceforge.net/tracker/index.php?func=detail&aid=3030538&group_id=180858&atid=894869 now.
Comment 27 Christoph Wickert 2010-08-27 17:57:25 EDT
*** Bug 626564 has been marked as a duplicate of this bug. ***
Comment 28 Christoph Wickert 2010-10-21 07:35:44 EDT
*** Bug 645270 has been marked as a duplicate of this bug. ***
Comment 29 Christoph Wickert 2010-10-21 21:15:29 EDT
*** Bug 645576 has been marked as a duplicate of this bug. ***
Comment 30 Christoph Wickert 2010-10-28 05:58:03 EDT
*** Bug 647415 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Wickert 2010-11-06 21:17:31 EDT
*** Bug 650551 has been marked as a duplicate of this bug. ***
Comment 32 Christoph Wickert 2010-11-22 17:11:21 EST
*** Bug 656020 has been marked as a duplicate of this bug. ***
Comment 33 Christoph Wickert 2010-12-15 12:18:07 EST
*** Bug 663368 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Wickert 2011-01-04 16:57:45 EST
*** Bug 667228 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Wickert 2011-02-13 14:55:55 EST
*** Bug 677166 has been marked as a duplicate of this bug. ***
Comment 36 Christoph Wickert 2011-02-21 11:18:13 EST
*** Bug 679112 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Wickert 2011-03-06 13:09:30 EST
*** Bug 682548 has been marked as a duplicate of this bug. ***
Comment 38 Christoph Wickert 2011-05-16 04:57:31 EDT
For the record: The correct upstream bug now is at
https://sourceforge.net/tracker/index.php?func=detail&aid=3030538&group_id=180858&atid=894869

Unfortunately it has not been resolved yet and after Marty left LXDE, lxpanel is de facto unmaintained.
Comment 39 Christoph Wickert 2011-05-23 06:08:31 EDT
*** Bug 706867 has been marked as a duplicate of this bug. ***
Comment 40 Christoph Wickert 2011-12-13 02:05:11 EST
*** Bug 767043 has been marked as a duplicate of this bug. ***
Comment 41 Christoph Wickert 2012-03-04 16:45:53 EST
*** Bug 799740 has been marked as a duplicate of this bug. ***
Comment 42 Christoph Wickert 2012-03-10 14:29:02 EST
*** Bug 802034 has been marked as a duplicate of this bug. ***
Comment 43 Christoph Wickert 2012-06-03 20:13:10 EDT
*** Bug 824164 has been marked as a duplicate of this bug. ***
Comment 44 Christoph Wickert 2012-06-10 02:25:54 EDT
*** Bug 830479 has been marked as a duplicate of this bug. ***
Comment 45 Christoph Wickert 2012-06-10 15:08:30 EDT
*** Bug 718159 has been marked as a duplicate of this bug. ***
Comment 46 Bastiaan Jacques 2012-09-29 13:57:13 EDT
(In reply to comment #38)
> For the record: The correct upstream bug now is at
> https://sourceforge.net/tracker/index.
> php?func=detail&aid=3030538&group_id=180858&atid=894869
> 
> Unfortunately it has not been resolved yet and after Marty left LXDE,
> lxpanel is de facto unmaintained.

The sourceforge tracker refers to task_draw_label, whereas this bug report crashes in flash_window_timeout... is that difference intentional?
Comment 47 Christoph Wickert 2012-09-29 14:24:40 EDT
Yes, upstream says it's the same bug.
Comment 48 Fedora Update System 2012-11-26 07:00:54 EST
lxpanel-0.5.10-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lxpanel-0.5.10-3.fc17
Comment 49 Fedora Update System 2012-11-26 07:02:17 EST
lxpanel-0.5.10-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lxpanel-0.5.10-3.fc16
Comment 50 Fedora Update System 2012-12-15 12:56:45 EST
lxpanel-0.5.10-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 51 Fedora Update System 2012-12-15 13:00:38 EST
lxpanel-0.5.10-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 52 David 2013-02-06 15:09:50 EST
I am running Fedora 18 with lxpanel --version 0.5.10 and encountered this same problem when closing Firefox.

There is no updated version in the fc18 repositories.
Comment 53 Fedora Update System 2013-02-12 14:58:21 EST
lxpanel-0.5.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lxpanel-0.5.12-1.fc18
Comment 54 Fedora Update System 2013-02-12 15:02:39 EST
lxpanel-0.5.12-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lxpanel-0.5.12-1.fc17
Comment 55 Fedora Update System 2013-02-28 01:58:08 EST
lxpanel-0.5.12-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 56 Fedora Update System 2013-02-28 02:06:03 EST
lxpanel-0.5.12-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 57 David 2013-04-22 13:56:11 EDT
Still happening with lxpanel 0.5.12, Fedora 18. What can I provide?
Comment 58 Bastiaan Jacques 2013-04-22 14:29:28 EDT
Created attachment 738614 [details]
(complete) fix

I sent in a fix that did not quite fix the problem. The attached patch solves the problem entirely, on my system. I have been too lazy to upstream it. Sorry :(
Comment 59 Christoph Wickert 2013-04-22 17:16:08 EDT
Thanks! Did you notify upstream about the new fix? I have commit access to the LXDE lxpanel git repository, but I don't want to commit without knowing if there are open bug reports.
Comment 60 Bastiaan Jacques 2013-04-22 17:31:18 EDT
(In reply to comment #59)
> Thanks! Did you notify upstream about the new fix? I have commit access to
> the LXDE lxpanel git repository, but I don't want to commit without knowing
> if there are open bug reports.

I have just done so, here: https://sourceforge.net/tracker/index.php?func=detail&aid=3573069&group_id=180858&atid=894871
Comment 61 Fedora Update System 2013-05-12 18:51:48 EDT
lxpanel-0.5.12-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lxpanel-0.5.12-2.fc17
Comment 62 Fedora Update System 2013-05-12 18:53:48 EDT
lxpanel-0.5.12-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lxpanel-0.5.12-2.fc18
Comment 63 Fedora Update System 2013-05-12 19:03:13 EDT
lxpanel-0.5.12-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lxpanel-0.5.12-2.fc19
Comment 64 Fedora Update System 2013-05-13 11:00:35 EDT
Package lxpanel-0.5.12-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxpanel-0.5.12-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8014/lxpanel-0.5.12-2.fc19
then log in and leave karma (feedback).
Comment 65 Christoph Wickert 2013-05-18 13:26:45 EDT
*** Bug 837379 has been marked as a duplicate of this bug. ***
Comment 66 Fedora Update System 2013-05-24 16:39:17 EDT
lxpanel-0.5.12-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 67 Fedora Update System 2013-05-29 22:55:46 EDT
lxpanel-0.5.12-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 68 Fedora Update System 2013-05-29 22:58:57 EDT
lxpanel-0.5.12-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.