Bug 837546 - Add mysql or mongodb to a scalable app lead to the stickshift-proxy crashed in stage
Add mysql or mongodb to a scalable app lead to the stickshift-proxy crashed ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 04:28 EDT by shjiang
Modified: 2015-05-14 18:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shjiang 2012-07-04 04:28:49 EDT
Description of problem:

Add mysql-5.1 or mongodb to a scalable app lead to the stickshift-proxy crashed
And i cannot connect to the mysql server. 

eg:
[root@jsq .ssh]# rhc app cartridge add -a pythonapp -c mysql-5.1 -p redhat

RESULT:
stickshift-proxy has crashed.


Version-Release number of selected component (if applicable):
stage-2.0.13

How reproducible:
Always


Steps to Reproduce:
1.create a scalable app using rest api or rhc app create command;
2.add mysql-5.1 or mongodb into this app;

  
Actual results:
RESULT:
stickshift-proxy has crashed.


Expected results:
RESULT:
Success.

Additional info:
1)after add mysql-5.1 to this scalable app, I use rhc domain show check the app:

[root@jsq .ssh]# rhc domain show -p redhat

User Info
=========
Namespace: shuiqing
  RHLogin: shjiang@redhat.com


Application Info
================
pythonapp
    Framework: python-2.6
     Creation: 2012-07-04T03:39:56-04:00
         UUID: 05c009a22f8d452cb8e2bd8658da2ee0
      Git URL: ssh://05c009a22f8d452cb8e2bd8658da2ee0@pythonapp-shuiqing.stg.rhcloud.com/~/git/pythonapp.git/
   Public URL: http://pythonapp-shuiqing.stg.rhcloud.com/

 Embedded: 
      haproxy-1.4
      mysql-5.1 - Connection URL: mysql://127.3.164.1:3306/

[root@jsq .ssh]# 

2) operate ssh to the server and execute mysql command,i get the error below:

[root@jsq .ssh]# ssh 05c009a22f8d452cb8e2bd8658da2ee0@pythonapp-shuiqing.stg.rhcloud.com

    *********************************************************************

    You are accessing a service that is for use only by authorized users.  
    If you do not have authorization, discontinue use at once. 
    Any use of the services is subject to the applicable terms of the 
    agreement which can be found at: 
    https://openshift.redhat.com/app/legal

    *********************************************************************

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with 'rhc app destroy'
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.

[pythonapp-shuiqing.stg.rhcloud.com ~]\> mysql
ERROR 2003 (HY000): Can't connect to MySQL server on '191fc3726e-shuiqing.stg.rhcloud.com' (111)

[pythonapp-shuiqing.stg.rhcloud.com ~]\> hostname
ex-std-node2.stg.rhcloud.com
Comment 1 Xiaoli Tian 2012-07-04 05:31:06 EDT
It's ok in latest devenv or INT except for stage.
Comment 2 Rob Millner 2012-07-05 19:28:16 EDT
I don't see this bug in stg right now; but we have been having DNS issues lately and its lead to some odd failures.

[rmtest-rlmstg.stg.rhcloud.com ~]\> echo $OPENSHIFT_DB_HOST
457cab4495-rlmstg.stg.rhcloud.com

[rmtest-rlmstg.stg.rhcloud.com ~]\> mysql
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 6
Server version: 5.1.61 Source distribution

Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> Bye
Comment 3 Rob Millner 2012-07-05 19:39:55 EDT
Embedded mongo and it works as well...

[rmtest-rlmstg.stg.rhcloud.com ~]\> mongo
MongoDB shell version: 2.0.2
connecting to: cb60b9b8bb-rlmstg.stg.rhcloud.com:42531/admin
> 
bye


I can't reproduce this problem.  Passing it back to Q/E to see if it still happens for them.
Comment 4 shjiang 2012-07-09 07:16:11 EDT
I test this bug in latest stg env. Add mysql or mongodb to scalable app is ok.
Comment 5 shjiang 2012-07-16 03:31:30 EDT
Version:
stage-2.0.14
rhc (0.95.13)

Test result:
the problem is fixed 

[root@jsq bin]# rhc app cartridge add -a pythonapp -c mysql-5.1 -p redhat

RESULT:

MySQL 5.1 database added.  Please make note of these credentials:

   Root User: admin
   Root Password: 94RBBpc9MICJ
   Database Name: pythonapp

Connection URL: mysql://08c4f6cf85-shuiqing.stg.rhcloud.com:48496/
MySQL gear-local connection URL: mysql://127.6.10.129:3306/

You can manage your new MySQL database by also embedding phpmyadmin-3.4.

[root@jsq bin]# rhc app cartridge add -a pythonapp -c mongodb-2.0 -p redhat

RESULT:

MongoDB 2.0 database added.  Please make note of these credentials:

       Root User: admin
   Root Password: _vHJD9iuri5T
   Database Name: pythonapp

Connection URL: mongodb://7809e7b97d-shuiqing.stg.rhcloud.com:48511/
MongoDB gear-local connection URL: mongodb://127.6.12.1:48511/

You can manage your new MongoDB by also embedding rockmongo-1.1

Note You need to log in before you can comment on or make changes to this bug.