Bug 837938 - STG: scalable applications not getting port numbers for proxy to subordinate gears.
STG: scalable applications not getting port numbers for proxy to subordinate ...
Status: CLOSED DUPLICATE of bug 834663
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks: 835529
  Show dependency treegraph
 
Reported: 2012-07-05 17:10 EDT by Rob Millner
Modified: 2015-05-14 18:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 19:16:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2012-07-05 17:10:29 EDT
Description of problem:

I created a scalable app and haproxy showed the serving gear as down.  Inspecting the haproxy configuration file showed that the port number was missing.

    server gear-a0b35a8d38-rlmstg 10.34.5.212: check fall 2 rise 3 inter 2000 cookie a0b35a8d38-rlmstg


Note the blank after "10.34.5.212:", there should be a port number.


Version-Release number of selected component (if applicable):
stage

How reproducible:
Started today; consistent.

Steps to Reproduce:
1. rhc app create -a rmtest -t php-5.3  -s 
2. Observe that the app is not reachable
3. Log in and inspect haproxy-1.4/conf/haproxy.cfg

  
Actual results:
No port number


Expected results:
A port number and a working proxy.


Additional info:
Comment 1 Rob Millner 2012-07-05 19:16:42 EDT

*** This bug has been marked as a duplicate of bug 834663 ***

Note You need to log in before you can comment on or make changes to this bug.