This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 837605 - RHN Satellite raises traceback about ip6addr when doing hardware sync from new clients (RHEL 6.3)
RHN Satellite raises traceback about ip6addr when doing hardware sync from ne...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
541
All Linux
high Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Martin Minar
:
Depends On: 822435
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2012-07-04 07:26 EDT by Jan Pazdziora
Modified: 2016-07-03 20:57 EDT (History)
9 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.13-75
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 822435
Environment:
Last Closed: 2012-07-23 11:33:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 124063 None None None 2012-07-17 16:46:09 EDT

  None (edit)
Description Jan Pazdziora 2012-07-04 07:26:17 EDT
+++ This bug was initially created as a clone of Bug #822435 +++

Description of problem:

If ipv6 is disabled in the client machine then running rhn-profile-sync raises traceback messages in the satellite server

How reproducible:
Always

Steps to Reproduce:
1. Register a rhel 6 machine to a satellite
2. Disable ipv6 in the rhel 6 machine
----------------------------
# cat /etc/modprobe.d/ipv6.conf
options ipv6 disable=1
# chkconfig --list |grep ip6tables
ip6tables      	0:off	1:off	2:off	3:off	4:off	5:off	6:off
---------------------------
3. Now execute rhn-profile-sync in the client machine


  
Actual results:
You will see following traceback message in /var/log/httpd/error_log or /var/log/httpd/ssl_error_log 
----------------------------
[Thu May 17 06:10:42 2012] [error] RHN 916 2012/05/17 06:10:42 -04:00: ("Unknown HW key =`ip6addr'", {'ip6addr': '', 'hostname': 'unknown', 'ipaddr': '10.65.209.196', 'class': 'NETINFO'}, {'class': None})
[Thu May 17 06:10:42 2012] [error] Exception reported from morbo.gsslab.rdu.redhat.com
[Thu May 17 06:10:42 2012] [error] Time: Thu May 17 06:10:42 2012
[Thu May 17 06:10:42 2012] [error] Exception type <type 'exceptions.KeyError'>
[Thu May 17 06:10:42 2012] [error] 
[Thu May 17 06:10:42 2012] [error] Exception Handler Information
[Thu May 17 06:10:42 2012] [error] Traceback (most recent call last):
[Thu May 17 06:10:42 2012] [error]   File "/usr/share/rhn/server/rhnServer/server_hardware.py", line 266, in __init__
[Thu May 17 06:10:42 2012] [error]     dict.dict())
[Thu May 17 06:10:42 2012] [error] KeyError: ("Don't know how to parse key `ip6addr''", {'ip6addr': '', 'hostname': 'unknown', 'ipaddr': '10.65.209.196', 'class': 'NETINFO'})
[Thu May 17 06:10:42 2012] [error] 

Expected results:
There won't be any tracebacks while executing rhn-profile-sync. The satellite should parse 'ip6addr' 

Additional info:
Seems like this already taken care in spacewalk 
http://spacewalk.redhat.com/documentation/python-doc/backend.server.rhnServer.server_hardware-pysrc.html

--- Additional comment from jhutar@redhat.com on 2012-05-30 17:21:34 CEST ---

Hello,
I have seen this as well:

  1. Have RHEL6 client (I have used Satellite itself) and Satellite 5.4.1
  2. Register client to Satellite and run rhn-profile-sync
  3. Check Satellite administrator's mail for traceback

I do not see this on RHEL5 and I'm not sure whether this is 100% reproducible on RHEL6.
Comment 1 Jan Pazdziora 2012-07-04 07:35:27 EDT
Reading the code (no reproducer yet), this patch could help:

diff --git a/backend/server/rhnServer/server_hardware.py b/backend/server/rhnServer/server_hardware.py
index f23e2d6..f13c338 100644
--- a/backend/server/rhnServer/server_hardware.py
+++ b/backend/server/rhnServer/server_hardware.py
@@ -348,7 +348,7 @@ class CPUDevice(Device):
 class NetworkInformation(Device):
     def __init__(self, dict = None):
         fields = ["hostname", "ipaddr"]
-        mapping = { 'class' : None }
+        mapping = { 'class' : None, 'ip6addr' : None }
         Device.__init__(self, "rhnServerNetwork", fields, dict, mapping)
         # use our own sequence
         self.sequence = "rhn_server_net_id_seq"
Comment 3 Jan Pazdziora 2012-07-04 10:12:45 EDT
Fix in SATELLITE-5.4, d1c3eb5b30adc92255a246adb38c520c68734ef1.
Comment 8 Robert Freeman-Day 2012-07-17 09:19:00 EDT
We are experiencing this issue.  Isn't this due to the enhancement from rhn-client-tools on the recent 6.3 updat?

https://bugzilla.redhat.com/show_bug.cgi?id=569790

https://bugzilla.redhat.com/show_bug.cgi?id=767679

I believe downgrading the rhn-client-tools seems to eliminate this.  So, the more servers that get that update, the more satellite admins will get flooded with emails about the traceback.  When is the estimated time this fix would come downstream?
Comment 9 Clifford Perry 2012-07-17 10:11:07 EDT
(In reply to comment #8)
> We are experiencing this issue.  Isn't this due to the enhancement from
> rhn-client-tools on the recent 6.3 updat?
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=569790
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=767679
> 
> I believe downgrading the rhn-client-tools seems to eliminate this.  So, the
> more servers that get that update, the more satellite admins will get
> flooded with emails about the traceback.  When is the estimated time this
> fix would come downstream?

The errata that this bug is associated too has 4 bugs to be QE tested before it
can be released. We are trying to get this released as soon as possible, keeping within our normal regression test cycles before release of an errata. 

Please open a support ticket to track, we can provide guidance for time estimates via the support ticket system. 

Regards,
Cliff
Comment 12 errata-xmlrpc 2012-07-23 11:33:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1108.html

Note You need to log in before you can comment on or make changes to this bug.