Bug 837614 - The "DHCP" should be marked "*" to show the network configured by using "DHCP" in network detail page
The "DHCP" should be marked "*" to show the network configured by using "DHCP...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 07:45 EDT by haiyang,dong
Modified: 2016-04-26 12:44 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
Previously, when invalid static network configuration settings were entered into the Red Hat Enterprise Virtualization Hypervisor TUI, the type was set to "static" for the runtime of the TUI and never changed during the runtime of the TUI, even if the configuration was successful changed to used DHCP. Now the correct configuration type is updated correctly when network configuration changes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:37:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of Network Detail Page (32.50 KB, image/png)
2012-07-04 07:45 EDT, haiyang,dong
no flags Details
dhcp+vlanID (44.08 KB, image/jpeg)
2012-10-31 01:25 EDT, cshao
no flags Details

  None (edit)
Description haiyang,dong 2012-07-04 07:45:30 EDT
Created attachment 596199 [details]
screenshot of Network Detail Page

Description of problem:
At first, configure network by using "Static" Protocol, keep "IP Address" label,"Netmask" label and "Gateway" label to blank and apply it,
then, configure network again by using "DHCP" Protocol, the network can be configured success, but the network detail page still displays that "Static" is marked "*" instead of "DHCP".

However, if input "IP Address","Netmask" and "Gateway" when configuring network by using "Static", this problem won't happen. 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120702.0.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H.
2. Configure network.
4. Enter network detail page and configure network by using "Static"
5. Keep "IP Address" ,"Netmask" and "Gateway" to blank and press the "apply" button direct.
6. Then configure this network interface again by using "DHCP"
7. Focus on Network detail page.

Actual results:
The network detail page still displays that "Static" is marked "*" instead of "DHCP" on TUI

Expected results:
The "DHCP" should be marked "*" to show the network configured by using "DHCP"

Additional info:

--
Comment 2 RHEL Product and Program Management 2012-07-10 02:33:01 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:53 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Mike Burns 2012-07-13 14:08:08 EDT
Simple fix:  don't allow configuration if IP Address, Netmask, Gateway aren't set.
Comment 5 Fabian Deutsch 2012-07-30 10:50:29 EDT
The problem was related to an in-tui caching of the previous (invalid) static network configuration data which never got reset.
Should be fixed with:

http://gerrit.ovirt.org/6767

Tested:
1. Install Node
2. Pull updated o-c-setup
3. Login
4. Configure network w/ dhcp
5. Configure network static, remove ip, gw and netmask
6. Press apply
(Error dialog appears)
7. Configure network w/ dhcp
8. Enter NIC details page, dhcp is marked
Comment 8 cshao 2012-10-31 01:24:44 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6.
ovirt-node-2.5.0-7.el6_4.noarch

Configure network with dhcp, enter NIC details page, dhcp is marked.
But configure network with DHCP+Vlan ID, disable is marked, so the fixed is incomplete, please see attachment.
Change bug status to ASSIGNED
Comment 9 cshao 2012-10-31 01:25:26 EDT
Created attachment 635945 [details]
dhcp+vlanID
Comment 10 cshao 2012-10-31 01:30:34 EDT
There is a bug 866585 for trace comment 8, so I will verify this bug after 866585 fixed.
Comment 16 errata-xmlrpc 2013-02-28 11:37:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.