Bug 866585 - Bootprotol is not shown for NICs with VLANID
Bootprotol is not shown for NICs with VLANID
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
: 865836 866584 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 12:39 EDT by Fabian Deutsch
Modified: 2013-02-28 11:40 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Previously, the boot protocol of a DHCP and VLANID configured network interface card (NIC) on the virtualised system, would revert to "Disabled". The bridge was only pulled from a NIC and not the potential clan children of the NIC. This lead to an incorrect boot protocol information report in the TUI. This patch now checks for potential clan children. Configuring DHCP with a VLANID should now set the configuration to "Configured".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:40:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-10-15 12:39:29 EDT
Description of problem:
After configuring a NIC with e.g. DHCP and a VLANID, the bootprotocol jumps back to "Disabled" b/c the bootprotocol of the "parent" NIC (ethX) is choosen, instead of using the bootprotocol of the "vlan-NIC" (ethX.Y)


Version-Release number of selected component (if applicable):
Current

How reproducible:
Always

Steps to Reproduce:
1. Configure NIC w dhcp and VLANID
2. Re-Enter NIC details page
3. 
  
Actual results:
NIC bootprotocol is set to "Disabled"

Expected results:
NIC bootprotocol is set to "DHCP"

Additional info:
The logic is just looking into the conf of the parent device.
Comment 3 Mike Burns 2012-10-16 07:29:26 EDT
*** Bug 865836 has been marked as a duplicate of this bug. ***
Comment 4 Fabian Deutsch 2012-10-18 08:53:55 EDT
http://gerrit.ovirt.org/8655
Comment 6 Fabian Deutsch 2012-10-19 03:59:23 EDT
Tested as follows:
1. Configure with DHCP
2. NIC shows up as "Configured", set to DHCP and driver is fine

3. Configure with DHCP and VLANID 20
4. NIC shows up as "Configured", set to DHCP, driver is fine and VLANID is 20

5. Disabling NIC
6. NIC shows up as "Unconfigured"
Comment 7 Mike Burns 2012-10-19 09:40:41 EDT
*** Bug 866584 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2013-02-28 11:40:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.