Bug 837695 - glibc sends spurious DNS requests for certain hostnames
glibc sends spurious DNS requests for certain hostnames
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.5
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Patsy Franklin
qe-baseos-tools
:
: 837696 837697 837698 854759 (view as bug list)
Depends On:
Blocks: 1003669
  Show dependency treegraph
 
Reported: 2012-07-04 17:05 EDT by Jeroen van Bemmel
Modified: 2016-11-24 10:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A buffer in glibc's resolver code was too small to handle results for certain DNS queries. Consequence: As a result, the query would have to be repeated after a larger buffer was allocated. This wastes time and network bandwidth. Fix: The buffer has been enlarged to handle the larger DNS results. Result: No extraneous DNS queries are generated.
Story Points: ---
Clone Of:
: 1003669 (view as bug list)
Environment:
Last Closed: 2013-02-21 02:05:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Potential fix (1.99 KB, patch)
2012-07-05 17:03 EDT, Jeff Law
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 14307 None None None Never

  None (edit)
Description Jeroen van Bemmel 2012-07-04 17:05:40 EDT
Description of problem:
A call to getaddrinfo() using glibc x86_64 results in duplicate DNS queries for the same A-record, causing redundant network traffic and extra delay for the client application. It may also break certain DNS-based load balancing schemes

Version-Release number of selected component (if applicable):
glibc latest HEAD

How reproducible: Always

Steps to Reproduce:
1. Start tcpdump using "udp port 53"
2. wget -4 www.google.com
  
Actual results:
2 DNS A queries + 2 identical answers for "www.google.com"

Expected results:
Single DNS A query + answer

Additional info:
See glibc bug report: http://sourceware.org/bugzilla/show_bug.cgi?id=14307
Comment 2 Jeff Law 2012-07-05 11:41:19 EDT
*** Bug 837696 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Law 2012-07-05 11:41:57 EDT
*** Bug 837697 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Law 2012-07-05 11:42:41 EDT
*** Bug 837698 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Law 2012-07-05 17:03:40 EDT
Created attachment 596504 [details]
Potential fix
Comment 6 Jeroen van Bemmel 2012-07-05 21:24:16 EDT
Comment on attachment 596504 [details]
Potential fix

A slightly different patch was submitted to the libc-alpha mailing list: http://sourceware.org/ml/libc-alpha/2012-07/msg00057.html

It will probably be committed into SVN tomorrow (Friday)
Comment 7 Jeff Law 2012-07-05 22:29:46 EDT
I'm aware of that change; the RHEL 6 codebase is slightly different and in fact doesn't have the codepath where the fix is being made upstream.
Comment 10 Jeff Law 2012-09-05 14:51:10 EDT
*** Bug 854759 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2013-02-21 02:05:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0279.html

Note You need to log in before you can comment on or make changes to this bug.