Bug 837696 - glibc sends spurious DNS requests for certain hostnames
glibc sends spurious DNS requests for certain hostnames
Status: CLOSED DUPLICATE of bug 837695
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.5
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 17:08 EDT by Jeroen van Bemmel
Modified: 2016-11-24 10:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 11:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 14307 None None None Never

  None (edit)
Description Jeroen van Bemmel 2012-07-04 17:08:02 EDT
Description of problem:
A call to getaddrinfo() using glibc x86_64 results in duplicate DNS queries for the same A-record, causing redundant network traffic and extra delay for the client application. It may also break certain DNS-based load balancing schemes

Version-Release number of selected component (if applicable):
glibc latest HEAD

How reproducible: Always

Steps to Reproduce:
1. Start tcpdump using "udp port 53"
2. wget -4 www.google.com
  
Actual results:
2 DNS A queries + 2 identical answers for "www.google.com"

Expected results:
Single DNS A query + answer

Additional info:
See glibc bug report: http://sourceware.org/bugzilla/show_bug.cgi?id=14307
Comment 2 Jeff Law 2012-07-05 11:41:19 EDT

*** This bug has been marked as a duplicate of bug 837695 ***

Note You need to log in before you can comment on or make changes to this bug.