Bug 837722 - First login after boot causes "Oh, no! Something has gone wrong" message
First login after boot causes "Oh, no! Something has gone wrong" message
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 21:00 EDT by Doug Hutcheson
Modified: 2013-08-01 06:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 06:17:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Hutcheson 2012-07-04 21:00:34 EDT
Description of problem:
After updating to FC17, whenever I boot the system, my first login attempt causes the "Oh, no! Something has gone wrong." message to appear. By using the Windows key, or moving the cursor to the top left corner of the screen, I can see the tiled applications I expect at startup all present and correct. Returning the cursor to the top left corner, or clicking on an application tile, returns me to the "Oh, no!" screen. If I click the log-out button, the system goes back to the login dialog. Logging in a second time works fine.


Version-Release number of selected component (if applicable):
uname -a
Linux cardraeh.farm.home 3.4.3-1.fc17.x86_64 #1 SMP Mon Jun 18 19:53:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Hardware: Lenovo T61 x86_64
I am running the proprietary Nvidia driver.

How reproducible:
Boot the system and log in.


Steps to Reproduce:
1. Boot to login dialog.
2. Log in as usual.
3. "Oh, no!" screen appears.
4. Click on the log-out button.
5. Log in again successfully.
  
Actual results:
The first login after boot triggers the "Oh, no! Something has gone wrong" screen.

Expected results:
Log in to a usable session.

Additional info:
The "Oh, no!" screen gives no hint as to what has triggered it and I see nothing meaningful (to me, a non-expert in the field) in var/log/messages. Is there another log I should be looking at?

I raised this at Fedora Forum: http://forums.fedoraforum.org/showthread.php?p=1588925#post1588925

Another Fedora Forum topic which may or may not be relevant: http://forums.fedoraforum.org/showthread.php?p=1588184

A search of Bugzilla did not turn up any similar bug reports involving the "Oh, no!" screen. The nearest candidate would be https://bugzilla.redhat.com/show_bug.cgi?id=710692, but the reporter does not mention whether the second attempt works OK. We are both running the proprietary Nvidia driver.

As an aside, would it be hard to get the "Oh, no!" message to report why it had been triggered? As it stands, it gives no hint as to the underlying problem and is almost MS Windows-like in its lack of helpfulness. Even a pointer to the log file(s) to examine would be helpful.
Comment 1 Andre Robatino 2012-07-05 19:21:17 EDT
I don't see this on bare metal using the proprietary Nvidia driver, but I do see it sometimes in my F16 and F17 VirtualBox guests. My guess was some kind of timing problem and the fact that during the second login, things are more likely to be cached.
Comment 2 Kit Gerrits 2012-08-09 05:56:23 EDT
I see the same thing on my FC17 VirtualBox guest.
The first login fails, both with GNOME and Cinnamon o.O

Relevant Versions:
[kgerrits@fc01 ~]$ cat /etc/redhat-release 
Fedora release 17 (Beefy Miracle)

[kgerrits@fc01 ~]$ uname -a
Linux fc01.csnlkgerrits.office.comscore.com 3.4.6-2.fc17.x86_64 #1 SMP Thu Jul 19 22:54:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

libgnome-2.32.1-3.fc17.x86_64
gnome-desktop3-3.4.2-1.fc17.x86_64
xorg-x11-drv-vmware-12.0.2-1.fc17.x86_64
VirtualBox v4.1.18 r78361, with extension pack installed
Comment 3 Doug Hutcheson 2012-08-17 21:52:45 EDT
I have just updated to kernel 3.5.2-1.fc17.x86_64 and noticed another possible clue: the first graphical login prompt after boot, the one which fails, has a white background: subsequent ones, which succeed, have a black background. A wild and knowledge-free guess is that the initial login prompt is generated by a different program than subsequent ones?
Comment 4 Parminder Lehal 2012-08-19 13:53:53 EDT
I started getting this error 2 weeks after updating to F17....after I ean yum update... I tried removing fprintd as suggested on some forums but did not help. Also, my computer is bare metal.......... so the issue is not limited to VMs.
Comment 5 Sergey 2012-08-24 07:09:36 EDT
On my F17 guest Virtualbox system this screen reproduced always.
My special settings - disabled USB support.
Comment 6 Doug Hutcheson 2012-09-03 03:29:57 EDT
I took my laptop away with me on holiday, away from my home WiFi network. Logging in was working consistently well, but the one WiFi hotspot I took it to would not let me log in: there was a password problem. As soon as I brought it back to my home WiFi network and let the laptop try to log in automatically at boot time, it started giving the 'Oh No' message again. I set the WiFi/Bluetooth hardware switch to 'Off' and rebooted. This time, my login worked fine. Once logged in, I set the WiFi/Bluetooth switch to 'On' and the network and mouse came up working fine.

As a result, I suspect there is something strange happening with either WiFi or Bluetooth connection at GUI login time.
Comment 7 Fedora End Of Life 2013-07-03 23:08:41 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2013-08-01 06:17:42 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.