Bug 837745 - TUI: RHEVH can't display NIC model in Network page when configuring network with vlanid
TUI: RHEVH can't display NIC model in Network page when configuring network w...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: TestOnly
Depends On: 872083
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 01:37 EDT by haiyang,dong
Modified: 2016-04-26 09:48 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the device dictionary used provide vendor information for ethernet devices failed when an ethernet device had a VLAN ID appended to it. Now, the VLAN ID is not considered when querying the device dictionary for vendor information.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:37:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of Network Page (98.62 KB, image/png)
2012-07-05 01:37 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-07-05 01:37:16 EDT
Created attachment 596331 [details]
screenshot of Network Page

Description of problem:
Configure network by using "DHCP" Protocol without vlanid, rhevh will display NIC model in Network page,
but if configure network by using "DHCP" with vlanid, rhevh won't display NIC model in Network page.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120702.0.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H.
2. Configure network.
3. Enter network detail page,and configure network by using "DHCP" with vlanid
4. Focus on Network page(Network page.png).

Actual results:
RHEVH can't display NIC model in Network page when configuring network with vlanid

Expected results:
RHEVH can display NIC model in Network page when configuring network with vlanid

Additional info:

--
Comment 2 RHEL Product and Program Management 2012-07-10 02:32:55 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:59 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Fabian Deutsch 2012-07-30 06:06:51 EDT
Previously vlan interfaces overwrote the informations of the original interfaces,t his lead to problems. Fixed with:

http://gerrit.ovirt.org/6757

Tested:
1. Install Node
2. Configure network (w/o vlanid)
(3. remount rw, pull update network.py, restart tui)
4. Configure network with vlanid
5. On network page: Vendor is visible
Comment 17 haiyang,dong 2012-12-14 02:50:55 EST
Test version:
rhev-hypervisor6-6.4-20121212.1.el6 
ovirt-node-2.5.0-11.el6

Steps
1. Install RHEV-H.
2. Configure network.
3. Enter network detail page,and configure network by using "DHCP" with vlanid
4. Focus on Network page.

Check that RHEVH can display NIC model in Network page when configuring network with vlanid. so this bug has been fixed, change the status into "VERIFIED".
Comment 19 errata-xmlrpc 2013-02-28 11:37:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.