Bug 837868 - ovirt node: standardize the bridge creation
ovirt node: standardize the bridge creation
Status: CLOSED DUPLICATE of bug 837443
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Kenigsberg
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 12:13 EDT by Douglas Schilling Landgraf
Modified: 2016-04-26 23:23 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 16:49:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Schilling Landgraf 2012-07-05 12:13:27 EDT
Description of problem:

   The autoinstall of oVirt Node creates the bridge in the system and in libvirt 
database. However, a manual installation the bridge is only created in the system, not in libvirt database. 

We could also think to remove the creation of the bridge since vdsm just remove it to create the ovirt bridge (ovirtmgmt).

How to reproduce:

Manual Install steps:
=========================

   - Execute a manual install
   - Using TUI setup the network
   - Press 'F2' in the TUI for shell
   - Type 'ifconfig' and you will see a bridge, example: 'brem1'
   - Using virsh check that there is no bridge listed in libvirt database
     # virsh --readonly net-list

Autoinstall
============================

   - Boot the oVirt Node ISO and press TAB and add the following parameters:
     storage_init=/dev/sda BOOTIF=em1 adminpw=RHhwCLrQXB8zE

    Note: admin password is 'redhat'

   - Press 'F2' in the TUI for shell
   - Type 'ifconfig' and you will see a bridge, example: 'brem1'
   - Using virsh check that there is no bridge listed in libvirt database
 
     # virsh --readonly net-list
     Name            State         Autostart
     -----------------------------------------
     vdsm-brem1      active        yes
Comment 1 Mike Burns 2012-07-05 13:16:38 EDT
After additional thought on this, it's not an ovirt-node issue.  ovirt-node does not, at any point, create a libvirt network.  

The only difference between the Manual TUI install and an autoinstall is a reboot between when the network is configured and when the vdsm-reg configuration runs.  

I ran 2 additional tests:

1.  TUI install, reboot, configure network, reboot

virsh --readonly net-list shows vdsm-breth0

2.  TUI install, reboot, configure network, systemctl restart vdsmd.service

virsh --readonly net-list shows vdsm-breth0

It appears that this libvirt network creation is done in vdsm and not in ovirt-node.


Given the above, this becomes a vdsm bug to either create the network when vdsm-reg runs, or handle a bridge that doesn't have a corresponding libvirt network.  


As for not creating bridges in ovirt-node at all, there are other use cases for ovirt-node that are not vdsm/ovirt-engine specific.  Those use cases generally do require that the bridge is created and a major change like that could cause significant problems for other consumers.
Comment 2 Douglas Schilling Landgraf 2012-07-09 16:49:14 EDT

*** This bug has been marked as a duplicate of bug 837443 ***

Note You need to log in before you can comment on or make changes to this bug.