Bug 837911 - initramfs won't find encrypted rootfs or usb keyboard won't work at password prompt for rootfs
initramfs won't find encrypted rootfs or usb keyboard won't work at password ...
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
Reported: 2012-07-05 15:42 EDT by Bruno Wolff III
Modified: 2012-07-09 20:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-07-09 09:03:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Log file from failed boot (84.32 KB, text/plain)
2012-07-07 12:18 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2012-07-05 15:42:22 EDT
Description of problem:
I yum upgraded a system from f17 to f18 Monday (finishing on Tuesday) and I cannot get it to boot with an initramfs made after the upgrade. I can boot with the one left behind from f17. I have another rawhide machine that does work, but the last time I ran dracut was on the weekend. I have been trying to revert dracut and systemd but with the changes going on recently I haven't been able to get a workable consistent set up packages from last week. The machine with the problem is an x86_64 machine and the one where it is working is i686 and does not use a USB keyboard, so in theory this could be a hardware specific issue.

I'm planning on trying to build a new initramfs on the machine where things are currently working to see if that breaks things. Trying to isolate the problem is further complicated by a systemd plymouth bug where booting with encrypted home fails and things need to manually get fixed up after waiting for time outs.

I also haven't seen consistent failure. Sometimes the boot will fail before switching video modes indicating that the file system specified in grub wasn't in /dev/mapper. Other times I get to the password prompt, but typing in the password does not result in asterisks being displayed nor the boot continuing.

The root file system is ext4 on luks on software raid.

Version-Release number of selected component (if applicable):
Comment 1 Harald Hoyer 2012-07-06 04:08:30 EDT
please boot with "rd.debug" and if you get dropped to a shell:

- mount any partition/usb stick
- run: # journalctl -a --no-pager > /mnt/<usb stick>/log.txt

and attach log.txt
Comment 2 Bruno Wolff III 2012-07-07 11:49:53 EDT
I tried to look at doing this, but another bug in systemd has been created preventing me from doing this. I might have a dump that shows you this bug, but it may be stopping too soon now. Also it is hard to get data off the system.
The x86_64 system is really hosed as the root fs got trashed while I was trying to get past the latest bug. I do think the same issue is happening on my i686 system, but I want to be more careful trying to recover. If I manage to get the saved data off I'll add what I got.
Comment 3 Bruno Wolff III 2012-07-07 12:18:33 EDT
Created attachment 596777 [details]
Log file from failed boot

I was able to get the logfile, but I am not sure if things got far enough to show the problem in this bug, before systemd got messed up.
Comment 4 Harald Hoyer 2012-07-09 02:43:11 EDT
does it work with selinux in permissive mode (add "enforcing=0" to the kernel command line)?
Comment 5 Bruno Wolff III 2012-07-09 07:38:29 EDT
Well it doesn't seem to make a difference, but I think I hit bug 838230 and this may be hiding this bug.
Comment 6 Bruno Wolff III 2012-07-09 07:56:35 EDT
It looks like I need to clean up from installing dracut-020-51 first. Once I get that done, I'll see if things get better. I also see there is a new dracut today to try out.
Comment 7 Bruno Wolff III 2012-07-09 09:03:45 EDT
This appears to be fixed with dracut-020-57.git20120709.fc18.
Comment 8 Bruno Wolff III 2012-07-09 20:00:39 EDT
Just as a followup, the unable to find an encrypted root partition issue is fixed. There still seems to be some usb related issues early in the boot, but I am seeing different behaviors for different kernels, so I need to look into it some more and will file a bug later. (Though maybe not against dracut.)

Note You need to log in before you can comment on or make changes to this bug.