Bug 837915 - Activation key including virtual type subscriptions from multiple hosts doesn't work.
Activation key including virtual type subscriptions from multiple hosts doesn...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On: 837151 995947 996688
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 15:47 EDT by Tom McKay
Modified: 2014-03-18 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 837151
Environment:
Last Closed: 2014-03-18 13:38:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-07-05 15:47:40 EDT
+++ This bug was initially created as a clone of Bug #837151 +++

Description of problem:

I tried to use an activation key which contains virtual type subscriptions derived from multiple hosts(HostA and HostB) to register a guest(on HostB), expecting Katello would choose one corresponding to its host(HostB). But it failed.

I'm not sure this is an intended behavior(i.e. a activation key should contain only one virtual type subscription). But if so, there must be a way to check the parent subscription of each virtual subscription as reported in:

https://bugzilla.redhat.com/show_bug.cgi?id=760564

Without that, I cannot choose a correct virtual subscription for a specific host.
Comment 1 Mike McCune 2012-08-08 11:29:22 EDT
We should only allow you to create activation keys for *one* host, not multiple.
Comment 2 Mike McCune 2014-03-18 13:38:32 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.