Bug 838049 - [libvirt] Domain's xml is broken after set numa parameters using numatune
[libvirt] Domain's xml is broken after set numa parameters using numatune
Status: CLOSED DUPLICATE of bug 828023
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 05:05 EDT by hongming
Modified: 2012-07-06 23:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 10:47:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hongming 2012-07-06 05:05:58 EDT
Description of problem:
Domain's  xml is broken after set numa parameters using numatune  

Version-Release number of selected component (if applicable):
kernel- 2.6.32-276.el6.x86_64
libvirt-0.9.13-2.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64


How reproducible:
100% 

Steps to Reproduce:
1.# virsh list --all
 Id    Name                           State
----------------------------------------------------
 -     rhel6u3                        shut off

2. # virsh numatune rhel6u3 --nodeset 1


3. # virsh numatune rhel6u3
numa_mode      : strict
numa_nodeset   : 1


3.# virsh dumpxml rhel6u3

<domain type='kvm' id='2'>
  ....
  <numatune>
    <memory mode='strict'   </numatune>
 
</domain>


4. # virsh start rhel6u3
error: Failed to start domain rhel6u3
error: (domain_definition):13: error parsing attribute name
    <memory mode='strict'   </numatune>
----------------------------^
  
Actual results:
The domain's xml is broken after set numa parameters using numatune 

Expected results:
It works fine after set numa parameters using numatune.

Additional info:
Comment 2 Alex Jia 2012-07-06 05:35:43 EDT
It's a known bug 828023.
Comment 3 Dave Allan 2012-07-06 10:47:11 EDT
(In reply to comment #2)
> It's a known bug 828023.

Closing as such.

*** This bug has been marked as a duplicate of bug 828023 ***

Note You need to log in before you can comment on or make changes to this bug.