Bug 838213 - SELinux is preventing /usr/sbin/httpd from 'execute_no_trans' accesses on the file /home/teppei/.gem/ruby/1.9.1/gems/passenger-3.0.13/agents/PassengerWatchdog.
SELinux is preventing /usr/sbin/httpd from 'execute_no_trans' accesses on the...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:bc6fdccf7fbfcc49e245fddfe1b...
:
: 838211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 05:00 EDT by teppei.takasaki
Modified: 2012-07-09 08:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 04:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: description (3.20 KB, text/plain)
2012-07-07 05:00 EDT, teppei.takasaki
no flags Details

  None (edit)
Description teppei.takasaki 2012-07-07 05:00:10 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.4-3.fc17.x86_64
time:           2012年07月07日 17時59分55秒

description:    Binary file, 3275 bytes
Comment 1 teppei.takasaki 2012-07-07 05:00:12 EDT
Created attachment 596744 [details]
File: description
Comment 2 Miroslav Grepl 2012-07-09 04:02:16 EDT
The problem is you installed it in your homedir. We have labeling for /usr/lib/ruby/gems/*.

Could you choose this location for it? If no, you will need add the passenger_exec_t label for

PassengerWatchdog, PassengerLoggingAgent, PassengerHelperAgent, ApplicationPoolServerExecutable

using

# chcon -t passenger_exec_t PATHO/PassengerWatchdog
Comment 3 Miroslav Grepl 2012-07-09 04:03:14 EDT
*** Bug 838211 has been marked as a duplicate of this bug. ***
Comment 4 teppei.takasaki 2012-07-09 08:59:31 EDT
I installed in /usr/share/gems, and SeLinux don't alert.

Thunk you.

Note You need to log in before you can comment on or make changes to this bug.