Bug 838229 - [abrt] colord-0.1.21-1.fc17: Process /usr/libexec/colord was killed by signal 6 (SIGABRT)
[abrt] colord-0.1.21-1.fc17: Process /usr/libexec/colord was killed by signal...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: colord (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:17d1ad20fe041e3de04a0f008c8...
:
: 839044 901817 920656 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 11:50 EDT by Luciano Coppola
Modified: 2013-04-24 06:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-24 06:32:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (6.39 KB, text/plain)
2012-07-07 11:50 EDT, Luciano Coppola
no flags Details
File: var_log_messages (10.01 KB, text/plain)
2012-07-07 11:51 EDT, Luciano Coppola
no flags Details
File: backtrace (11.28 KB, text/plain)
2012-07-07 11:51 EDT, Luciano Coppola
no flags Details

  None (edit)
Description Luciano Coppola 2012-07-07 11:50:56 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/colord
executable:     /usr/libexec/colord
kernel:         3.4.4-3.fc17.i686.PAE
pid:            896
pwd:            /
time:           sab 07 lug 2012 17:10:58 CEST
uid:            996
username:       colord

backtrace:      Text file, 11549 bytes
maps:           Text file, 6544 bytes
var_log_messages: Text file, 10252 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/system/colord.service
:2:cpuset:/
:1:name=systemd:/system/colord.service

core_backtrace:
:1b7a8044899df495e307686069c93efcf4dd9272 0x424 __kernel_vsyscall linux-gate.so.1 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x2e95f raise libc.so.6 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x302b3 abort libc.so.6 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x6a799 g_assertion_message libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x6ada0 g_assertion_message_expr libglib-2.0.so.0 -
:312d48a6f1cc4d6c09956dc213b10952925c88a3 0x14b0c - [exe] -
:d0b2ee750bf29544a82c25b03f3fe22086c6c4be 0xbfe3c - libgio-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x44a31 - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x46feb g_main_context_dispatch libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x47390 - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x477f3 g_main_loop_run libglib-2.0.so.0 -
:312d48a6f1cc4d6c09956dc213b10952925c88a3 0x60b3 main [exe] -

dso_list:
:/usr/lib/gconv/gconv-modules.cache glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/lib/libgthread-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1341504898
:/usr/lib/librt-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/lib/libpthread-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/lib/libgobject-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1341504898
:/usr/lib/libpolkit-gobject-1.so.0.0.0 polkit-0.104-6.fc17.i686 (Fedora Project) 1341505555
:/usr/lib/libffi.so.5.0.10 libffi-3.0.10-2.fc17.i686 (Fedora Project) 1341504892
:/usr/lib/libresolv-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/share/locale/it/LC_MESSAGES/glib20.mo glib2-2.32.3-1.fc17.i686 (Fedora Project) 1341504898
:/usr/lib/libsqlite3.so.0.8.6 sqlite-3.7.11-3.fc17.i686 (Fedora Project) 1341504890
:/usr/lib/libsystemd-login.so.0.2.1 systemd-44-17.fc17.i686 (Fedora Project) 1341505549
:/usr/lib/libm-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/libexec/colord colord-0.1.21-1.fc17.i686 (Fedora Project) 1341505784
:/usr/lib/libgio-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1341504898
:/usr/lib/libgudev-1.0.so.0.1.1 libgudev1-182-3.fc17.i686 (Fedora Project) 1341505554
:/usr/lib/libgmodule-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1341504898
:/usr/share/locale/it/LC_MESSAGES/libc.mo glibc-common-2.15-37.fc17.i686 (Fedora Project) 1341504862
:/usr/lib/libz.so.1.2.5 zlib-1.2.5-6.fc17.i686 (Fedora Project) 1341504880
:/usr/lib/libglib-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1341504898
:/usr/lib/libudev.so.0.13.1 libudev-182-3.fc17.i686 (Fedora Project) 1341505539
:/usr/lib/locale/locale-archive glibc-common-2.15-37.fc17.i686 (Fedora Project) 1341504862
:/usr/lib/libc-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/share/locale/it_IT/LC_MESSAGES/colord.mo colord-0.1.21-1.fc17.i686 (Fedora Project) 1341505784
:/usr/lib/libselinux.so.1 libselinux-2.1.10-3.fc17.i686 (Fedora Project) 1341504879
:/usr/lib/liblcms2.so.2.0.3 lcms2-2.3-2.fc17.i686 (Fedora Project) 1341504944
:/usr/lib/libdl-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/lib/ld-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1341504867
:/usr/share/locale/it/LC_MESSAGES/colord.mo colord-0.1.21-1.fc17.i686 (Fedora Project) 1341505784

environ:
:SYSFONT=True
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
:LANG=it_IT.UTF-8
:KEYTABLE=it
:BOOT_IMAGE=/vmlinuz-3.4.4-3.fc17.i686.PAE
:HOME=/var/lib/colord
:LOGNAME=colord
:USER=colord

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             16007                16007                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       16007                16007                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:socket:[18300]
:pos:	0
:flags:	02
:2:socket:[18300]
:pos:	0
:flags:	02
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:socket:[19296]
:pos:	0
:flags:	02004002
:5:socket:[19297]
:pos:	0
:flags:	02004002
:6:/var/lib/colord/mapping.db
:pos:	40
:flags:	02100002
:7:/var/lib/colord/storage.db
:pos:	2048
:flags:	02100002
:8:socket:[18301]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002

smolt_data:
:Traceback (most recent call last):
:  File "/usr/bin/smoltSendProfile", line 152, in <module>
:    profile = smolt.get_profile()
:  File "/usr/share/smolt/client/smolt.py", line 1414, in get_profile
:    return Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 1004, in Hardware
:    _hardware_instance = _Hardware()
:  File "/usr/share/smolt/client/smolt.py", line 591, in __init__
:    self.host = Host()
:  File "/usr/share/smolt/client/smolt.py", line 306, in __init__
:    self.systemVendor = cat('/sys/devices/virtual/dmi/id/sys_vendor')[0].strip()
:  File "/usr/share/smolt/client/devicelist.py", line 76, in cat
:    fd = open(file, 'r')
:IOError: [Errno 2] File o directory non esistente: '/sys/devices/virtual/dmi/id/sys_vendor'
Comment 1 Luciano Coppola 2012-07-07 11:50:59 EDT
Created attachment 596772 [details]
File: maps
Comment 2 Luciano Coppola 2012-07-07 11:51:02 EDT
Created attachment 596773 [details]
File: var_log_messages
Comment 3 Luciano Coppola 2012-07-07 11:51:04 EDT
Created attachment 596774 [details]
File: backtrace
Comment 4 Richard Hughes 2013-04-24 06:32:01 EDT
Fixed with this:

commit b3f7557d27c2542006c6c6bc2d1b8175dd112b16
Author: Christopher James Halse Rogers <raof@ubuntu.com>
Date:   Fri Aug 31 13:23:32 2012 +1000

    Initialise global connection variable earlier.
    
    Under some circumstances the on_name_acquired handling is done on
    an idle callback, and it's always done asynchronously, after the
    dbus name has been acquired. Thus there is a race between another
    dbus client noticing colord has acquired its name and the
    on_name_acquired callback being fired. If a client makes a dbus
    request in this time, connection will be NULL, and colord will
    die with an assertion.
    
    Moving the setting of connection to on_bus_acquired removes this
    race because the dbus objects are only registered later in
    on_bus_acquired.

:100644 100644 a3771cf... 77e15d8... M  src/cd-main.c
Comment 5 Richard Hughes 2013-04-24 06:32:53 EDT
*** Bug 839044 has been marked as a duplicate of this bug. ***
Comment 6 Richard Hughes 2013-04-24 06:37:22 EDT
*** Bug 901817 has been marked as a duplicate of this bug. ***
Comment 7 Richard Hughes 2013-04-24 06:41:02 EDT
*** Bug 920656 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.