Bug 838713 - %include broken in %pre/%post section of kickstart
%include broken in %pre/%post section of kickstart
Status: CLOSED DUPLICATE of bug 827269
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Unspecified
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 18:13 EDT by Kevin Masaryk
Modified: 2013-04-02 19:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 19:33:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Masaryk 2012-07-09 18:13:49 EDT
Description of problem:
Including the %include directive in the %pre or %post section of a kickstart file followed by a file name produces an error during parsing.

Version-Release number of selected component (if applicable):
Fedora 17

How reproducible:
Always

Steps to Reproduce:
1. In either the %pre or %post section of a kickstart, copy a file from an external source to the local filesystem. For example,

  mkdir /tmp/mnt
  mount -t nfs 1.2.3.4:/export /tmp/mnt
  cp /tmp/mnt/foofile /
 
2. Include the file from step 1 in the kickstart with the %include directive:

  %include /foofile

* Add '--erroronfail' to the %pre or %post line being used to more easily see the error.
  
Actual results:
The installation will halt with an error similar to the following:

  fg: no job control

Expected results:
File text should be included into the ks as documented in:

http://fedoraproject.org/wiki/Anaconda/Kickstart#Chapter_4._Pre-installation_Script

Additional info:

* Error is generated whether file actually exists or not.
Comment 1 Brian Lane 2012-07-09 19:33:30 EDT

*** This bug has been marked as a duplicate of bug 827269 ***

Note You need to log in before you can comment on or make changes to this bug.