Bug 827269 - ksflatten ignoring nested includes
ksflatten ignoring nested includes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 819672 838713 846835 (view as bug list)
Depends On:
Blocks: 819672
  Show dependency treegraph
 
Reported: 2012-05-31 21:16 EDT by Joey Boggs
Modified: 2013-04-10 10:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: pykickstart-1.99.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-10 10:31:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
failed flatten (4.29 KB, text/plain)
2012-05-31 21:16 EDT, Joey Boggs
no flags Details
successful flatten (30.69 KB, text/plain)
2012-05-31 21:17 EDT, Joey Boggs
no flags Details
patch (2.95 KB, patch)
2012-06-13 19:27 EDT, Brian Lane
no flags Details | Diff

  None (edit)
Description Joey Boggs 2012-05-31 21:16:39 EDT
Created attachment 588226 [details]
failed flatten

ksflatten seems to ignore nested %includes and places the section directly into the resulting kickstart.

1.99-4.1 from F16 works fine, 1.99-11 through 18 aren't working


# ovirt16 Node image recipe
%include common-install.ks
%include ovirt16-install.ks
%include repos.ks

%packages --excludedocs --nobase
%include common-pkgs.ks
%include ovirt16-pkgs.ks
%end

%post
%include common-post.ks
%include ovirt16-post.ks
%end

%post --nochroot
%include common-nochroot.ks
%end

%include image-minimizer.ks
%include common-manifest.ks

attaching resulting kickstart, not sure if something has changed in syntax or just a bug
Comment 1 Joey Boggs 2012-05-31 21:17:24 EDT
Created attachment 588227 [details]
successful flatten
Comment 2 Mike Burns 2012-06-13 17:51:06 EDT
Any chance someone can look at this?  This is strongly impacting oVirt-node.  It forces us to manually roll back to the F16 version of pykickstart and prevent ever updating it.

Thanks
Comment 3 Brian Lane 2012-06-13 19:27:35 EDT
Created attachment 591669 [details]
patch
Comment 4 Mike Burns 2012-06-14 09:31:58 EDT
*** Bug 819672 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2012-06-18 13:18:12 EDT
I built 1.99.12 before lunch, but didn't push yet.  This'll be fixed in 1.99.13 instead.
Comment 6 Brian Lane 2012-07-09 19:33:30 EDT
*** Bug 838713 has been marked as a duplicate of this bug. ***
Comment 7 Mike Burns 2012-07-12 07:26:47 EDT
I see the build in F18, but can this be built for F17 as well?  This is a significant pain point for building ovirt-node and keeping the build machines relatively up to date.  

Thanks
Comment 8 Pavel Zhukov 2012-08-03 02:45:48 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=4353353

This build works for me
Comment 9 Brian Lane 2012-08-09 12:31:45 EDT
*** Bug 846835 has been marked as a duplicate of this bug. ***
Comment 10 Mike Burns 2012-08-09 12:43:53 EDT
The F18/rawhide build works for me too, but it would be much appreciated if we could backport this fix into F17 as well.

Any chance of that happening?
Comment 11 Fedora Update System 2012-08-09 15:01:07 EDT
pykickstart-1.99.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pykickstart-1.99.15-1.fc17
Comment 12 Fedora Update System 2012-08-10 18:32:36 EDT
Package pykickstart-1.99.15-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.15-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11727/pykickstart-1.99.15-1.fc17
then log in and leave karma (feedback).
Comment 13 Netbulae 2012-08-28 07:39:22 EDT
Works for me, many thanks!!

Note You need to log in before you can comment on or make changes to this bug.