Bug 838808 - Rebase libtdb to version 1.2.10
Rebase libtdb to version 1.2.10
Status: CLOSED DUPLICATE of bug 766335
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libtdb (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 04:09 EDT by Andreas Schneider
Modified: 2012-07-10 10:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 10:48:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Schneider 2012-07-10 04:09:24 EDT
Description of problem:

We will rebase samba to version 3.6 in RHEL6. Samba 3.6 requires a newer libtdb version which provides a new hashing function. The old hashing algorithm is still supported and the database will not be upgraded to a newer version until the user (e.g. Samba) opens it with a special flag.

Samba 3.6 migrates all tdb's to the new hashing function to fix bugs and improve performance. The new hashing function is magnitudes faster than the old version.

Application which are not aware of the new hashing algorithm will not see any change. They still can simply add a flag to gain the performance boost too.
Comment 2 Andreas Schneider 2012-07-10 10:48:41 EDT

*** This bug has been marked as a duplicate of bug 766335 ***

Note You need to log in before you can comment on or make changes to this bug.