This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 838814 - Rebase libtalloc to version 2.0.7
Rebase libtalloc to version 2.0.7
Status: CLOSED DUPLICATE of bug 766335
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libtalloc (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 04:17 EDT by Andreas Schneider
Modified: 2012-07-10 10:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 10:52:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andreas Schneider 2012-07-10 04:17:46 EDT
Description of problem:

For Samba 3.6 we need libtalloc 2.0.7 which fixes important bugs. talloc doesn't ensure that the sibling list of a pointer doesn't become invalid  during a free operation. This causes segfaults in Samba, especially in spoolss.

This is required to rebase samba to 3.6, see bug #649479.

The talloc testsuite has been extended that we don't regress in the talloc_free case anymore. Also for other bugs unit tests have been added.
Comment 2 Andreas Schneider 2012-07-10 10:52:24 EDT

*** This bug has been marked as a duplicate of bug 766335 ***

Note You need to log in before you can comment on or make changes to this bug.